Jump to content

A tool to backup HG/SS saves


Pokedoc

Recommended Posts

  • Replies 427
  • Created
  • Last Reply

Top Posters In This Topic

I tried the latest version, but it crash when i start it. SO I'm using 0.24 version. I'm backuping pokemon soul silver. The ftp server and connection(with wep key) are working: if I use rudolph tool(with compatible games like pokemon pearl) it wors well. So i think that the problem isn't the ftp server or the connection.

Link to comment
Share on other sites

DSaveManager can backup 3ds saves; don't know if it supports games with an IR port (like Soul Silver).

http://3dbrew.org/wiki/DSaveManager

Also, just for reference:

-What loader are you using for both v3 and v2.4?

-Have you tried putting both the config and nds file in the root of your MicroSD? (Makes a difference with some loaders and some homebrew, not necessarily this one).

Link to comment
Share on other sites

  • 4 weeks later...

the reason .30 crashes is that the language variable in the ini is commented out. copy the ini, app, and the template.ini out of the lang folder and put them all in the root of your sd card.

So it your root dir should look like

/

savegame_manager.nds

savegame_manager.ini

template.ini

Then change the line from #language = /sgm_german.ini to language = /template.ini

save, exit, pop your SD back in your flashcart, start it up, and it should work.

Also I'd like to say that if there's ever a .31, I really hate the auto-mode-selection. It'd be much nicer if there were a menu that allowed us to pick which mode we wanted to use, as I prefer to run my slot2 homebrew from my slot1, and with the auto-select.. even with the program patched to read/write from/to my EZ4, if run from my slot1 it starts in GBA mode.

Link to comment
Share on other sites

How should I set it up for my SuperCard DSTwo?

that's a bit vague since you haven't mentioned if you plan to dump over wifi or dump to slot 2. If you're dumping over wifi you have to make sure your access point is WEP or unprotected and VISIBLE.. you can't hide your SSID or the homebrew won't be able to find it if I recall correctly. set your DS up for your access point if you haven't already.

after that, figure out what your computers IP address is on your LAN, either by finding it on your router's page, or by opening CMD and running ipconfig /all (and trying to find something like 192.168.x.y

Once that's figured out you open your savegame_manager.ini and change the ip address to the address of your computer. for my computer that's 192.168.4.42

Open your router's page and make sure the port that the manager connects to (it's FTP so.. 21) is open for incoming connections on your computer's LAN IP address. Some routers don't have port forwarding/opening options so if you have a DMZ setting instead you can put your computers IP in that and set that.. but turn DMZ off after you're done dumping/restoring because that opens ALL ports to and from your computer.

Open an ftp server.. I think the one suggested to use with this is Smallftpd? and make sure that connecting to it with the user and pass in the "savegame_manager.ini" will work. If not, change the ini to match your server settings.

With your server open and your port open.. and your ini saved with your configuration, start up the savegame_manager.nds. It should go straight to wifi mode if you don't have anything in your slot2. from there you should be able to dump your save.. albeit slowly. I don't think I've ever restored a save over wifi so I'm not sure how that works exactly, but the process is probably similar.

Ed: oh and make sure you apply the edits in my previous post as well. if you don't remove the # from the language line and change the path to the language ini, the program will still crash.

Link to comment
Share on other sites

  • 4 weeks later...
  • 2 weeks later...
can someone please tell me step by step how to restore games?

it just gets stuck at Reading FTP directory and won't show the .sav

If it's what you're saying, I think I'm having the same problem.

I can connect to SmallFTP with my DS, in doing so it says (on the DS):

"FTP: Connecting to AP"

"FTP: Connecting to FTP server"

and then, "FTP: dir"

Nothing else is being displayed on the DS screen. No directory folder tree of any kind.

Meanwhile, on SmallFTP, it is showing the activity of being connected to. Though instead of the usual "connected" type message I remember before (it's been a few months since I've last played with it), it'll say:

"Connecting..."

"#0 - test - TYPE A (/)" (Note: this appears very briefly.)

and then "#0 - test - PASV (/)" And that is all it displays.

I could understand if it was not connecting at all, then it'd be an issue of a Port or IP number being off somewhere. I can work with that.

But I'm at a complete loss with this. It's connecting, but it's not displaying any file folders of any kind on the DS. It just simply says "FTP: dir"

Meanwhile, SmallFTP simply says "#0 - test - PASV (/)"

I understand that "test" is my smallftp account name, but I cannot understand why its not displaying directories on the ds. I've selected the right directory in which to draw from already and everything.

If it's something stupid I'm missing, please tell me.

To reiterate the directories thing, I've gone under Users > Edit > and under Directories, I have it listed as / --> C:/Smallftp specified under the Physical Path. This is where the save file I want to restore back onto the real cartridge. The filename should match the original that came off of it.

Link to comment
Share on other sites

Hey,

I have been trying things for about an hour, but I always end up on this screen:

XWVxn3r

http://imgur.com/XWVxn3r

Also, my smallftp says PASV beside my username, even if I have all the rights activated.

Second issue, as you may see, there are no paths, even if the folder exits, is set correctly in smallftp and everything.

This is on .2.4

EDIT: DSavemanager says only to restore 3ds saves, why? will it kill my pokemon white save if I use it?

Thank you for any help

Link to comment
Share on other sites

  • 2 weeks later...

How did you get this to work?

I have an Acekard 2i and an NDS Light and Pokemon Black.

When i start the app and click on backup it says take out the slot 1 card. okay i take it out. But when i put in my Pokemon black my ndsl restarts and start pokemon.

if you dont understand what i am meaning ive maked a liitle video of my problem, look here https://app.box.com/s/atqwh4iy2ar2hbgbmxqt

Can some one help me?

Link to comment
Share on other sites

Does your cartridge have a save file saved on it?

People were reporting similar problems with B2W2, which were fixed by first saving in-game to create a save file, then they were able to restore from a .sav on their flashcard without any issues.

Link to comment
Share on other sites

Does your cartridge have a save file saved on it?

People were reporting similar problems with B2W2, which were fixed by first saving in-game to create a save file, then they were able to restore from a .sav on their flashcard without any issues.

Yes it has a sav file look

IMG_20130822_151510.jpg

But i dont want to restore, i want to dump the sav to put it on my acekard. But my DS restarts after put in pokemon so i cant backup the sav :/

edit: okay its working now :D the trick is to put in a gba game in slot 2 and take it out before put in the slot 1 game

Edited by ChaOS2307
Link to comment
Share on other sites

  • 2 weeks later...

I need help.

I have setup save game manger 3.0 and it runs without any problems. I setup smallftp and configured it into the .ini. I put pokemon Pearl into my DSlite and configured the wifi setting and it connects without any problems.

I'm using a r4i3ds gold.

I run the app, pull out the cart, insert game, and it says something about connecting to Internet and to please wait. It never connects.

What am I doing wrong?

Link to comment
Share on other sites

Ok, so I loaded the older version in but it's still not working.

I'm getting the message: FTP connecting to AP

Small ftpd 1.0.3 is up and running. It's configured.

My ds lite won't auto detect my linksys wifi. So, I did a manual set up and tested the connection and it worked. I even was able to send pokemon to my sister's game with pokegen. But I can't connect to AP to save pokemon Diamond. There has to be a solution to what is wrong.

I finally figured it out. I didn't broadcast my Internet. I now have all my games backed up.

Edited by Aj3537
Link to comment
Share on other sites

  • 3 weeks later...
  • 5 weeks later...

Did anyone get the Slot-2 backup mode to work using EZ-Flash IV?

I patched the binary with what seemed to be the right DLDI driver and then patched it to .ds.gba using the tools found with the EZ4Client download, but when I try to boot the homebrew, it just hangs on a white screen.

I got it to work. What I did was patch it to .ds.gba first, then I DLDI patched it.

After that, I deleted everything but the first four lines of the .ini file, then I put savegame_manager.ds.gba along with savegame_manager.ini on my EZ-Flash IV's miniSD, then I was able to start it up and backup save files successfully.

I'm not sure why, but when I keep the original .ini file with all of the extra stuff in it, it hangs on a black screen, but it loads properly when all it has is the ftp information.

Not even sure why it was hanging on a white screen the first time around either, but it works now.

Edited by Guest
Link to comment
Share on other sites

I'm having the same exact issue as Chaos2307

I have an Acekard2i with the latest fw (legit hardware) and I'm trying to backup my Black 2 save. There is a savefile on it. However, neither .3 or .24 work for me.

I replace the card as it says, and the DS restarts. it is a DS Lite. Any help would be appreciated.

Link to comment
Share on other sites

http://filetrip.net/nds-downloads/flashcart-files/download-ez4-client-2009-04-03-f31119.html

Used the dldi file and the programs in the "HOMEBREW AND DLDI" folder.

First patch the .nds binary to add the small gba header (cmd: dsbuild.exe savegame_manager.nds), then dldi patch it (cmd: dlditool.exe ezsd.dldi savegame_manager.ds.gba)

Then open up savegame_manager.ini and delete everything past the first four lines (keep just the ones about the ftp address, user and password basically.) <-- Might not be needed, but the program would hang on a black screen every time if I didn't.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...