Jump to content
Sign in to follow this  
Champloo

Legendary Beast Glitch?

Recommended Posts

I've been looking everywhere for this information as I've heard it before and I just wanted to get some confirmation...has anyone ever heard of the Legendary Beasts Glitch in FireRed/LeafGreen where the random beast will have VERY LOW IVs like 0...something like that...I need to see if this is completely true as I've heard about it but yet cannot find ANY info on it...

Anyone know?

Share this post


Link to post
Share on other sites

I've heard of it, too, but some detailed info is relatively scarce.

But they do have crap IVs, as I've done experiments where I gather as many Kanto dogs as possible and check IVs. It's usually 5 zeroes and one other number, normally lower than 10.

The glitch really takes a rough toll on the poor dogs. :/

Share this post


Link to post
Share on other sites
I've heard of it, too, but some detailed info is relatively scarce.

But they do have crap IVs, as I've done experiments where I gather as many Kanto dogs as possible and check IVs. It's usually 5 zeroes and one other number, normally lower than 10.

The glitch really takes a rough toll on the poor dogs. :/

Tell me about it. I've been searching over 2 hours for good information but have had no luck and ya that's what I heard something about how 5 or around there will have 0 in the IVs and the other one still incredibly low...I'm asking because I need to back up a STATEMENT but have had no luck in doing so...

So again does anyone have any info regarding this glitch?

Share this post


Link to post
Share on other sites

It's true. Many have confirmed that their Legendary Dogs had ridiculously low IV's. Usually anywhere around 0.

Share this post


Link to post
Share on other sites
It's true. Many have confirmed that their Legendary Dogs had ridiculously low IV's. Usually anywhere around 0.

Do you know of any sites/sources where I can read up on this?

Share this post


Link to post
Share on other sites

SCV told me in his own words:

There is a glitch in the function that generated the pkm that will go into your party/box from the roamer information. Before its copied, the data is fine, but in the process, the IVs are not copied correctly so you end up being able to get up to 31 in HP and 7 in Atk.

For the ones from Colosseum, they don't suffer the same problem.

Yes, roamers, including the Lati twins of RSE, suffer this problem. The Lati in Southern Island does not though.

Source:

1. http://projectpokemon.org/forums/showpost.php?p=19897&postcount=132

Share this post


Link to post
Share on other sites
SCV told me in his own words:

Yes, roamers, including the Lati twins of RSE, suffer this problem. The Lati in Southern Island does not though.

Source:

1. http://projectpokemon.org/forums/showpost.php?p=19897&postcount=132

Wait I thought that the only Reason Latias/Latios in Ruby/Sapphire had bad IVs was because they were determined when you STARTED the game. I've Soft Reset for a Latias in Emerald before so I know in Emerald they fixed it to where the IVs are determined when you Press A On the TV and pick the color.

But as for the Roamers in FR/LF I am not sure. But from what you posted...it is without a doubt confirmed?

Share this post


Link to post
Share on other sites

Why do you think all the Latis that you've seen had terrible IVs? Their IVs were okay from the start (or not... but it was predetermined)... until they get captured... then the IVs become 0 across the boards. Is that mere coincidence? Try catching one from Southern Island... and you'll see the clear difference.

Let's say the Lati rogue had 31/14/15/24/15/8 IVs... then once captured it will become something like 31/7/0/0/0/0 IVs... ouch that's painful X_X

Share this post


Link to post
Share on other sites
Why do you think all the Latis that you've seen had terrible IVs? Their IVs were okay from the start (or not... but it was predetermined)... until they get captured... then the IVs become 0 across the boards. Is that mere coincidence? Try catching one from Southern Island... and you'll see the clear difference.

Let's say the Lati rogue had 31/14/15/24/15/8 IVs... then once captured it will become something like 31/7/0/0/0/0 IVs... ouch that's painful X_X

=\ I think you must have the Pokemon I'm talking about confused...I know the Lati's in Ruby/Sapphire are going to have bad IVs because there IVs are predetermined once you start a new game thus there is no WAY to soft reset (Technically there is but you'd have to start a new game EACH TIME and play through it until you could catch the Lati which is really unrealistic) I have Soft Reset for a Latias in Emerald (They fixed the glitch in Emerald)

ANYWAYS

I'm talking about the Legendary Beats (Dogs, Cats, Gerbils, whatever you may call them) in FR/LG.

P.S. I might have misread your post so I MIGHT BE THE ONE WRONG lol sorry

Share this post


Link to post
Share on other sites

Read that statement made by SCV above... I bolded the part which applies to BOTH the legendary beasts AND the Latis... the IVs being copied down wrong is why. They start out with predetermined IVs or whatnot and end up with 0 everywhere after being captured. The IVs were transferred incorrectly. And I had no idea Emerald's Latitwins IVs were fixed.

Share this post


Link to post
Share on other sites
Read that statement made by SCV above... I bolded the part which applies to BOTH the legendary beasts AND the Latis... the IVs being copied down wrong is why. They start out with predetermined IVs or whatnot and end up with 0 everywhere after being captured. The IVs were transferred incorrectly. And I had no idea Emerald's Latitwins IVs were fixed.

Oh ok I see but as far as the Emerald LAti's I can confirm that they fixed it since I did SR for my Latias =]

Share this post


Link to post
Share on other sites

As was posted, I confirmed that there is a bug in the proccess that copies the IVs that are stored for the pokemon that you are trying to capture to the one that goes to your team or box when you catch it.

This bug affects R/S/FR/LG. It was fixed for Emerald.

In R/S the PID/IVs of the roamer are set when you see the TV after beating the pokemon league.

In FR/LG they are set after you fix the machine in island one.

You can SR in all cases. but The IVs are a max of 31/7/0/0/0.

Share this post


Link to post
Share on other sites

That is disappointing. Nintendo made two big bugs in Pokemon Ruby and Sapphire. And Pokemon Fire Red and Leaf Green that has a fix for the berry glitch has a bug of its own...

I wounder if there are other undiscovered bugs in the games.

Share this post


Link to post
Share on other sites
As was posted, I confirmed that there is a bug in the proccess that copies the IVs that are stored for the pokemon that you are trying to capture to the one that goes to your team or box when you catch it.

This bug affects R/S/FR/LG. It was fixed for Emerald.

In R/S the PID/IVs of the roamer are set when you see the TV after beating the pokemon league.

In FR/LG they are set after you fix the machine in island one.

You can SR in all cases. but The IVs are a max of 31/7/0/0/0.

That's terrible... is there any way to get past this glitch? These IV's are just terrible.

Share this post


Link to post
Share on other sites
As was posted, I confirmed that there is a bug in the proccess that copies the IVs that are stored for the pokemon that you are trying to capture to the one that goes to your team or box when you catch it.

This bug affects R/S/FR/LG. It was fixed for Emerald.

In R/S the PID/IVs of the roamer are set when you see the TV after beating the pokemon league.

In FR/LG they are set after you fix the machine in island one.

You can SR in all cases. but The IVs are a max of 31/7/0/0/0.

I'm going to assume that the missing IV would still be zero (you only posted 5 lol). But thanks for confirming. So until HG/SS come out Soft Resetting for the three Legendary Beasts is only possible through Colosseum (Or xD?) regardless that's the only way then. Bummer Nintendo should really work a little bit better when it comes to this. I mean SERIOUSLY. Thanks again SCV very much appreciated.

That is disappointing. Nintendo made two big bugs in Pokemon Ruby and Sapphire. And Pokemon Fire Red and Leaf Green that has a fix for the berry glitch has a bug of its own...

I wounder if there are other undiscovered bugs in the games.

Probably not anything major or we probably would have noticed by now (as far as anything IMPORTANT goes).

That's terrible... is there any way to get past this glitch? These IV's are just terrible.

There is no way around this. Bummer aint' it?

Share this post


Link to post
Share on other sites
That is a bummer. I'm just glad that we can get past this with HG and SS. How was this even discovered in the first place?

I think just after everyone caught there legendary and started noticing the IVs were ridiculously low they must have tested it then.

My guess. =\

Share this post


Link to post
Share on other sites

Just to make sure I understand this:

The HP IV is copied normally.

The Attack IV is copied normally, BUT if it's above 7, it will go down to 7.

All other IVs are set to zero.

Is this right?

Share this post


Link to post
Share on other sites
Just to make sure I understand this:

The HP IV is copied normally.

The Attack IV is copied normally, BUT if it's above 7, it will go down to 7.

All other IVs are set to zero.

Is this right?

All the IVs are copied normally but regardless can only be a max of: 31/7/0/0/0/0

This is do to the glitch which there is no way around. Thus the only way to get a decent Legendary Beast is through xD.

Or until HG/SS comes out.

Share this post


Link to post
Share on other sites

The Attack IV is copied normally, BUT if it's above 7, it will go down to 7.

Is this right?

That's not how it works its through a bit shift and.

Share this post


Link to post
Share on other sites

The IVs are stored as a 30bit integer, based on two 16bit integers. If I remember correctly the problem is when the two 16bit integers are converted to the 30bit integer, it has to do a "& 0x3FFFFFFF" operation. However, the bug is that it does "& 0xFF" instead.

Share this post


Link to post
Share on other sites

Ok, now I think I get it:

According to Bulbapedia, IVs are stored as:

SpDef/SpAtk/Speed/Defense/Attack/HP

Where each stat takes 5 bits (so it ranges from 0-31.)

So 31 IVs in every stat would be:

11111/11111/11111/11111/11111.

Normally all these would be copied normally since it's doing an AND operation with all 1's (& 0xFFFFFF or whatever).

However, since it is doing an AND operation with only 0xFF, only the last 8 bits are copied correctly, and the rest becomes zeros:

Original IVs: 25/14/31/5/2

In binary:......00010/00101/11111/01110/11001

After & 0xFF: .00000/00000/00000/00110/11001

Which is now 25/6/0/0/0/0.

So to sum it up:

HP IV is copied normally.

Def, SpAtk, SpDef, and Speed all become zero.

Attack IV becomes:

If originally 16 or higher, subtract 16 from it.

If it is still 8 or higher, subtract 8 from it.

Am I understanding all this right?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...