Jump to content
Xishu

Issue creating Pokemon with PKHeX in Sword/Shield?

Recommended Posts

Pokemon that I edit that I legit hatched myself (evee) does appear to change into the game file? Im using latest version of checkpoint.

The pokemon stay the same with no changes made?

I edit there natures, and IVS only...

Share this post


Link to post
Share on other sites

Hmm, after trying it with EdiZon my problem was gone? Could be that Checkpoint is not fully compatible with my system? I'm running latest switch firmware, and latest custom firmware.

Edited by WolfieX

Share this post


Link to post
Share on other sites

I still have a problem: I can't edit Pokemon or create new one out of the blue . Only thing that works is editing items.

 

I tried extracting my save with edizon and jksv, both go with the same result.

What am I missing?

Share this post


Link to post
Share on other sites
On 11/22/2019 at 4:21 PM, Ishzark said:

I still have a problem: I can't edit Pokemon or create new one out of the blue . Only thing that works is editing items.

 

I tried extracting my save with edizon and jksv, both go with the same result.

What am I missing?

do you have the 112519 edition?  if not its a free download.  everything works for me.

Share this post


Link to post
Share on other sites
On 11/16/2019 at 5:06 AM, Ishzark said:

I also have trouble creating mons

 

When I create them,it says legality ok.

 

When I boot the savegame they are gone but dex entry says I own them

I'm having the same issue. Lemme know if you find out anything please.

Share this post


Link to post
Share on other sites

Long time pkhex user since XY, and I've never had any issues until recently.

I edited a whole box, but when I saved it to my main save file none of it was there. I double checked that i was hitting "Set".

Happened again. Third time around,, I kept a Pkhex window open with all my edits - saved it but did not close it.

I then re-opened another window , loaded my newly saved main file, only to see my changes still didn't cross over again. I saved all my newly edited mons as pk8s and injected them manually and then it worked and saved.  I usually edit the main file with no problems or saving pk8s, but lately have to double and triple check before uploading into Checkpoint.

The problems are not happening when editing Pokedex, bag items, money, BP. etc - That crosses over fine - only boxes are the issues.

Thank you for all your work and help....i know this version is still in its early Gen8 stages.
 

EDIT: I switched from using Checkpoint to Edizon and it works much better, as has been reported in this post. Checkpoint is glitchy.

Edited by ethicalflow
New findings

Share this post


Link to post
Share on other sites

I had tried to insert "OT/Misc" / Latest (not OT) Handler to simulate trade evolution of Onix/Steelix and it's ok!

Share this post


Link to post
Share on other sites
2 hours ago, cheope82 said:

I had tried to insert "OT/Misc" / Latest (not OT) Handler to simulate trade evolution of Onix/Steelix and it's ok!

that's what I was suspecting.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...