Jump to content

File Size Too Large (Pokemon Platinum)


Recommended Posts

Hello, this is my first post here so I apologize if I'm doing something wrong. My issue is that my platinum save won't work with PKHex because it's too large. I edited this save before with no issues, but at the time the save was less than 600 kb. Now however, it's over 1000 kb. My save's not corrupt because I'm still playing fine and I made a backup. Thank you so much for any help 
<file removed due to file name>

Link to comment
Share on other sites

On 12/23/2020 at 4:57 AM, culturedminecrafter said:

Hello, this is my first post here so I apologize if I'm doing something wrong. My issue is that my platinum save won't work with PKHex because it's too large. I edited this save before with no issues, but at the time the save was less than 600 kb. Now however, it's over 1000 kb. My save's not corrupt because I'm still playing fine and I made a backup. Thank you so much for any help
<file removed due to file name>

No idea why your save file size changed. Could be related to your emulator settings.

Anyhow, all I had to do is cut away the excess data.
<file removed due to file name>

Link to comment
Share on other sites

  • Kaphotics changed the title to File Size Too Large (Pokemon Platinum)
4 minutes ago, culturedminecrafter said:

Aight, so I got HxD, got the 2 files, compared them, but don't know what to do next. I don't know to cut the excess data. Again, I seriously apologize for being dumb.

For Pokemon Platinum:
image.png

Regular DSVs end here. Anything past here should be removed.

Nothing fancy, that's all I did to your previous file.

Link to comment
Share on other sites

9 minutes ago, culturedminecrafter said:

In mine, theres nothing after, so does that mean the files fine? The right one is yours and the left one is the one I'm trying to fix.77697878_Screenshot(157).thumb.png.c73dc8360cae3001e5a561999856ac8a.png

Dude look at what I highighted on the left of my image. Go to that value in your file. Think of that as the address for the row of data.
(it increases at every row: 0x0, 0x10, 0x20, 0x30, so on and so forth)

Your address is much larger, which shows your file is much larger.

Link to comment
Share on other sites

I've finally done it, and just realized what caused the file to grow. Apparently when I imported a save it merged with the autogenerated file and grew in size. Meaning every time I want to use PKHex, I have to trim it. Thanks for your help. Final question is do I always cut from that row or will it be different every time?

Link to comment
Share on other sites

6 minutes ago, culturedminecrafter said:

The problem with that is Desmume doesn't recognize the file when you put in the battery folder. It generates its own and recognizes that.

There's probably something wrong with your settings. Desmume can open PKHeX edited DSVs directly.
Maybe you're editing the dsv in a dupe battery folder or something. who knows.

An alternative, would be to save the game, export battery file as .sav, import the .sav into PKHeX,
then save the progress from PKHeX as a .sav (when done editing), then import battery file into the emulator, then soft reset.

When you import battery file, make sure to go with this option:
image.png

Link to comment
Share on other sites

8 minutes ago, culturedminecrafter said:

This is not too much of a problem because I'm not gonna be using pkhex 24/7. The problem at hand now is that PKHex won't accept the save. As for saving, I did and the option is still not here. 

Screenshot (160).png

Few things come to mind, so I'll just address the points
1. Probably something off with your Desmume settings. It shouldn't just ignore your previous save and start over. Is your auto save type Internal (as I showed a few posts prior)
As double check your Path Settings to ensure it's reading and write to and from the right place.
2. PKHeX would not ignore the save, as long as (i) it's the right size and (ii) properly initialized.
You could upload the save here, but I'm guessing it's probably not properly initialized. Make sure you save in-game, not just use state saves.

Link to comment
Share on other sites

2 minutes ago, culturedminecrafter said:

It's the save I trimmed from my gameplay.

The usage of trimmed here is slightly concerning. It makes it sound like you took the oversized DSV, edited it (downsized it), and renamed it .sav.

when the game is running normally, and a save is loaded, you're supposed to export via this.
image.png

Link to comment
Share on other sites

On 12/24/2020 at 6:47 AM, culturedminecrafter said:

I just copied it from the folder. If that was wrong and the file is corrupt now its fine cause I made a backup.

Sigh, I frankly do not know what is right or wrong with your system anymore. For now, try importing this into your game. then save in-game.
<file removed due to file name>

then use the export and import steps in the future.

Link to comment
Share on other sites

1 minute ago, culturedminecrafter said:

The file you just sent me had the use import option. I exported it, tried it in PKHex and it worked! Thank you so much! I'm sorry for hurting your brain cells.

It's possible the save you used (or the save you trimmed) weren't a proper save and were of the wrong size, hence the option wasn't there, and PKHeX wouldn't open it.

As long as the importing and exporting option continue to work properly, you shouldn't have any problems. No worries :3

Link to comment
Share on other sites

  • 3 months later...
On 12/23/2020 at 12:11 AM, theSLAYER said:

No idea why your save file size changed. Could be related to your emulator settings.

Anyhow, all I had to do is cut away the excess data.
<file removed due to file name>

I also downloaded hxd so I wanna learn what count as excess data

 

lol.dst

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...