Jump to content

Has anyone managed to make a Linux build for PKHeX?

Recommended Posts

I'm pretty sure this or similar questions have been asked before, but all I see are different answers.


I would like to know if anyone has managed to build PKHeX to use it on Linux. At least in part.


I ask because I've pretty much been trying to build, find and use PKHeX for Linux Ubuntu 20.04. I don't know a lot of coding, but I don't see guides that really helps with knowledge.


I've been trying to build with Visual Studio, MonoDevelop... And there is always an error or warning. Is it even POSSIBLE for me to build it in a way so I can I use on Linux without needing Windows or its .NET Core? I really don't like Windows.


I've tried wine. It loads, but with a lot of errors and it can't open Sword or Shield saves. Whenever I move the mouse to the box, it shows and error, so, basically I can't do anything with it.


PKHeX for me does not work since Sword and Shield support came. I'm pretty sure it has to do with .NET Framework, I believe.


Trying to find a solution that doesn't require Windows. If some of its dependencies are required, I prefer the minimal.


Thanks in advance.

Edited by Night Light
Fix grammar errors
Link to post
Share on other sites

I have the latest wine, and, to my understanding I have .NET Framework 4.6.


Gotta double check wine tricks.


(Wine version is the latest stable by the way).

Edited by Night Light
Added information.
Link to post
Share on other sites

I’m not aware of any issues with wine-stable-5.0.1 that would prevent .Net from being installed.


As I spend the majority of my time in macOS I use a CrossOver-19 based compile (Wine-4.12.1 with thousands of patches)


Just make a clean 32Bit prefix then run

winetricks -q dotnet46


Once that’s done you should be all set as long as all wines requirements are installed

  • Like 1
Link to post
Share on other sites

Thanks for the help, I managed to get it working now.


It didn't work at first, but it turns out that was just a problem with internet connection. After I fixed that, I installed .NET with winetricks again and it worked.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...