Jump to content
  • Dumping Games for pkNX ROM Editing/Randomization

      In this guide I'll be going over the (very) simple process of dumping your Nintendo Switch Pokémon titles for use with pkNX. This will work with the following games:
    • Pokémon: Let's Go, Pikachu! / Pokémon: Let's Go, Eevee!
    • Pokémon Sword / Pokémon Shield*
    * For Sword and Shield, pkNX operates under the assumption that your dumped ROM includes the Ver. 1.3.0 patch.

    What you'll need:
    • A Nintendo Switch running Custom Firmware (preferably Atmosphère)
    • The latest release of NXDumpTool
    • The latest build of pkNX (steps on how to get the latest build can be found on its forum post)
    • Your console keys/title keys (you can obtain these files using Lockpick_RCM; send the RCM payload to your console, dump keys from your specified NAND, and boot into CFW)
    • A microSD Card with enough free space to dump your game (~5GB for LGPE, ~13GB for SWSH)
    • Means of transferring files between your microSD Card and computer
    • A computer running any recent Windows OS (x64) in order to run pkNX

    Steps:
    1. Get into The Homebrew Menu as per your Custom Firmware
    2. Run NXDumpTool
    3. Select Dump gamecard content if you have a physical copy of the game, and make sure your Game Card is inserted
    4. Select Dump installed SD card / eMMC content if you have a digital copy of the game, and navigate to your game of choice
    5. Select RomFS options
    6. Navigate to Use update/DLC and press Right on your D-Pad to change it from No to the latest patch
        The latest patch will read as follows, depending on your game:
        (Ver. 1.0.2) Pokémon: Let's Go, Pikachu! - 010003F003A34000 v131072 (0.0.2.0) (UPD)
        (Ver. 1.0.2) Pokémon: Let's Go, Eevee! - 0100187003A36000 v131072 (0.0.2.0) (UPD)
        (Ver. 1.3.0) Pokémon Sword - 0100ABF008968000 v327680 (0.0.5.0) (UPD)
        (Ver. 1.3.0) Pokémon Shield - 01008DB008C2C000 v327680 (0.0.5.0) (UPD)
        (Ver. 1.3.1) Pokémon Sword - 0100ABF008968000 v393216 (0.0.6.0) (UPD)
        (Ver. 1.3.1) Pokémon Shield - 01008DB008C2C000 v393216 (0.0.6.0) (UPD)

    7. Navigate back to the top of the list and select RomFS section data dump
        This process will take some time; be patient, let it properly dump all of the contents and don't power off your console!
    8. Once the dumping process has completed, exit out of NXDumpTool and access your SD Card (either via ftpd, nxmtp, or by ejecting the SD Card from your console and putting it in your computer)
    9. Your dumps will be located in the following path on your SD Card: sd:/switch/nxdumptool/
    10. Inside the RomFS folder, you should be greeted to your ROM dump
    11. The folder inside RomFS will be named after your ROM dump (e.g. Pok__mon Sword v393216 (0100ABF008968000) (UPD)); move this folder to your computer
    12. Run pkNX and load the folder you just moved to your computer
    13. Edit/randomize away!

    Once your changes have been made, a patch folder for use with LayeredFS will be generated in your ROM dump folder.
    Move this folder to sd:/atmosphere/contents/ (or whichever other location if you choose to not use Atmosphère) in order for your changes to be reflected in-game.

    • Like 4


    User Feedback

    Recommended Comments

    I have tried to move the Folder "0100ABF008968000" into my Asmosphere/Content folder also tried to make a titles folder in my Atmosphere and neither of them are randomizing my game. Do you know why this is?

    Share this comment


    Link to comment
    Share on other sites

    I don't have the option "01008DB008C2C000 v327680 (0.0.5.0) (UPD)" but only the option "0100ABF008968800 v393216 (0.0.6.0) (UPD) (eMMC)".

    when i dump it and try to opne it pkNX gives me an error saying that the folder was invalid and it couldn't recognise game data. what can i do to fix it?

    Share this comment


    Link to comment
    Share on other sites
    6 minutes ago, Alpha64 said:

    I don't have the option "01008DB008C2C000 v327680 (0.0.5.0) (UPD)"

    This option is for Pokemon Shield
     

    Quote

    but only the option "0100ABF008968800 v393216 (0.0.6.0) (UPD) (eMMC)".

    And this is for Pokemon Sword.

    7 minutes ago, Alpha64 said:

    opne it pkNX gives me an error saying that the folder was invalid and it couldn't recognise game data.

    did you combine the files (obtained from Update dump) with the base game dump?
    (as in use the base game dump as the main folder, then paste in the content from the update, and replace if the prompt appears)

    Share this comment


    Link to comment
    Share on other sites
    1 minute ago, theSLAYER said:

    did you combine the files (obtained from Update dump) with the base game dump?

    no i didn't. do i have to?

    Share this comment


    Link to comment
    Share on other sites
    2 minutes ago, Alpha64 said:

    no i didn't. do i have to?

    I would think so. The update doesn't contain the full game, does it?

    Share this comment


    Link to comment
    Share on other sites
    Just now, theSLAYER said:

    I would think so. The update doesn't contain the full game, does it?

    NXDumpTool says that it dumped both the base game and the update though

    Share this comment


    Link to comment
    Share on other sites
    Just now, Alpha64 said:

    NXDumpTool says that it dumped both the base game and the update though

    It's been a while since I used the tool, so I can't remember for sure.
    One way you can confirm it, is to check the folder size of the base game, versus the folder size of the folder you have.

    Another thing to consider, is to make sure you have the latest version of pkNX.

    If you have the right folder, and it's not working, then I got no clue. Maybe gotta wait for a new version?

    Share this comment


    Link to comment
    Share on other sites
    3 minutes ago, theSLAYER said:

    check the folder size of the base game, versus the folder size of the folder you have.

    the base folder is around 9GB if i remember correctly wwhile the folder i use is more than 12GB

    3 minutes ago, theSLAYER said:

    make sure you have the latest version of pkNX

    i should but i'm not 100% sure about it. where can i find it?

    Edited by Alpha64
    removed "the" before it

    Share this comment


    Link to comment
    Share on other sites
    1 minute ago, Alpha64 said:

    the base folder is around 9GB if i remember correctly wwhile the folder i use is more than 12GB

    i should but i'm not 100% sure about it. where can i find it?

    yeah that seems like the right size.
     


    Check the first post for download link, as well as a mini pictorial to download it

    Share this comment


    Link to comment
    Share on other sites
    7 minutes ago, theSLAYER said:

    Check the first post for download link, as well as a mini pictorial to download it

    it worked! thank you so much!

    Share this comment


    Link to comment
    Share on other sites

    Ive tried doing this multiple times with different ways of nxdump and no matter what i do i keep getting this error message

     

    pknx.PNG

    Share this comment


    Link to comment
    Share on other sites

    This is likely due to not having an updated dump. PKNX assumes you have 1.3.0, so if the ROMfs you're feeding it doesn't have it, it's gonna break.

    Took me a while to figure that out.

    Share this comment


    Link to comment
    Share on other sites
    18 minutes ago, Trelior said:

    This is likely due to not having an updated dump. PKNX assumes you have 1.3.0, so if the ROMfs you're feeding it doesn't have it, it's gonna break.

    Took me a while to figure that out.

    I don't think that's the issue.

    I have 2 dumps. Look at my gift IDs.
    image.pngimage.png
    First dump's list ends at 26, second dump's list ends at 30.

    If I'm not mistaken, first dump is only at IoA (1.2.0), and second dump is definitely 1.3.1
    I can also open common on both just fine.

    So the issue *probably* isn't due to patch versions. Probably.
    @Trelior which update version of the game did you supposedly dump?

    Share this comment


    Link to comment
    Share on other sites

    @theSLAYER I had a 1.2.0 dump that refused to open the Pokemon Tab. It would throw an error similar to @Tricksta, and just die. I have since deleted it, since I have no reason to keep it.

    I just dumped 1.3.1 with a bit of jank due to disk space problems on my SD card, but that's an entirely different thing that I solved on my own. Everything opens as expected now, I can set the randomization to work on everything except Trainers. and I'm getting this error when hitting the Randomize button.

    image.png.ef570675ffb058f3d61adcf0e2e761e2.pngimage.png.526ea01d3e22c38b2f003c27722d4e35.png

    Everything else opens and randomizes as expected.

    EDIT: Changed my attachment to show the full exceptions dialogue, sorry for the clutter.

    Edited by Trelior

    Share this comment


    Link to comment
    Share on other sites

    i cant use pknx

    image.png.f5e5ccd163bd3b93f43f4d3099116de7.png

     

    Is it because my game is updated to ver 1.3.1?

    Share this comment


    Link to comment
    Share on other sites
    38 minutes ago, F0rest19 said:

    i cant use pknx

    image.png.f5e5ccd163bd3b93f43f4d3099116de7.png

     

    Is it because my game is updated to ver 1.3.1?

    No. I can load my v1.3.1 just fine. Consider dumping the files from a Switch, as the tutorial shows.

    Share this comment


    Link to comment
    Share on other sites


    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

×
×
  • Create New...