Jump to content
FromCrimsonToWool

Emerald Save Restore Glitch Research

Recommended Posts

There is an bug with Pokémon Emerald save restoring. A few of the clock-based events don't trigger/reset properly when you transfer/restore a save from an emulator to an Emerald cart, but the in-game clock and other time based events will still function properly.

I'm determined to find out why this happens. Moreover, I will find a proper fix for this( and there’s no harm in me learning a whole lot in the process :-) ).

This is a call for as much additional information, no matter how seemingly trivial it may be. It’s seems that this is an issue related to the RAM and/or save state.

Observations:

  • the Lillycove lottery never resets
  • secret base trainers never reset( I’ve got a SWEET setup with 6 level 100 Blissey’s that have no attacking moves for BOATLOADS of experience )
  • the clock in the player’s bedroom continues to run properly
  • the man in Pacifidlog that
    gives out Frustration or Return TMs still does so

Theories/ideas:

  • placeholder

Questions that need to be answered:

  • Is this a problem with the emulator, a problem with the save restoring & backup program, both, or something else entirely?
  • Is this permanent?
  • Does this type of thing only happen to Emerald or do Ruby and Sapphire suffer, too?
  • I know that there are MANY people that know spellbinding amounts not just about programming in general, but also about the specific programming of these generation III games. Where else should I ask for help?
  • Will someone please provide a ‘known good’ save( i.e. a save backup from a cart that is working properly )?
  • It has been surmised that this occurred after they beat the Elite Four, is this true or just coincidence?
  • MrEobo posted that someone told him the issue is worked out if the game isn’t played for a while. I don’t think this is true as my cart hasn’t seen much play in a long while and still has the issue, but is there a way to positively confirm or deny this?

Edited by FromCrimsonToWool
Changed to an é

Share this post


Link to post
Share on other sites

This is, indeed, becoming a nuisance xD

I'm not sure when I started noticing that some time based events no longer occur correctly, but I believe it was just randomly. I might start a new game on Emerald, transfer the save file a few times early in the story, and see if this problem still occurs, or if there is something specific that triggers it.

Share this post


Link to post
Share on other sites

I have started a new save file on my Emerald version.

Not much to say about it, but the fact that I've used homebrew transferring software and edited the save file with Encyclopedia Pokemon a few times, and in-game events still run normally, along with my player's house clock.

I will soon test whether or not actually playing the save file on the VBA emulator *without* using "Real-Time Clock" will affect in-game events. If it doesn't affect them, then the only way to *prevent* this problem will be by not using the Real-Time Clock on VBA. Still no answer to a 'fix', per se.

Share this post


Link to post
Share on other sites

I played the Emerald U ROM on VBA with my cartridge save file *without* enabling the Real-Time Clock, injected the save back into the cartridge, and timed events still resume normally. I even watched news on one of the televisions for the Berry Crushing Master! I might back up my save file and try playing with the real-time clock enabled or maybe some AR codes to see if it affects the in-game time events.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...