Butterfree 1967

Invalid terminators in Pokemon Name and my OT in Pokegen beta v.3.24

6 posts in this topic

Like the title says, no matter what I make, I upload the file to pokecheck, and everything is valid except this:

Pokemon Name or Nickname ends in invalid terminators

my OT ends in invalid terminators

I have the correct OT/TID/SID input every time

what am I doing wrong? Is this normal?

I would like these pokemon I am making to be valid, as this is the only thing pokecheck comes up with in red for me.

any help is appreciated!!!!

Share this post


Link to post
Share on other sites

Is it an event Pokemon or from Gen IV? If so you may need to trashbytes it (drag the file onto the .exe that comes with Pokegen). The only other thing I can think of is that Pokecheck isn't perfect quite yet and it's just giving you a bad return.

Share this post


Link to post
Share on other sites
Is it an event Pokemon or from Gen IV? If so you may need to trashbytes it (drag the file onto the .exe that comes with Pokegen). The only other thing I can think of is that Pokecheck isn't perfect quite yet and it's just giving you a bad return.

That is nOT the issue.

I am making 5G pokemon, in pokegen, and using pokecheck to check them.

when I do the same with a pokemon from the actual game, everything is valid, but when it comes from pokegen, I always get the same result with the invalid terminators in OT and pokemon name/nickname no matter what!!!

Pokecheck can't be giving me a false positive if the converted pokemon from my game come out ok, but the ones from pokegen do not!

I am thinking it may be a bug in pokegen, as it is still in beta

Share this post


Link to post
Share on other sites
That is nOT the issue.

I am making 5G pokemon, in pokegen, and using pokecheck to check them.

when I do the same with a pokemon from the actual game, everything is valid, but when it comes from pokegen, I always get the same result with the invalid terminators in OT and pokemon name/nickname no matter what!!!

Pokecheck can't be giving me a false positive if the converted pokemon from my game come out ok, but the ones from pokegen do not!

I am thinking it may be a bug in pokegen, as it is still in beta

Regardless so long as your PID, location met, and IVs/EVs check out you should be fine. I wouldn't worry about it.

Share this post


Link to post
Share on other sites

If your pokémon has an invalid terminator it is a clear evidence that it was edited in Pokegen and is reported as such in Pokécheck. Pokegen does not generate correct trash bytes by default, possibly by design. this thread will tell you what is considered a valid terminator sequence, but in any case trash bytes have absolutely no effect in game so you shouldn't worry about it.

Share this post


Link to post
Share on other sites
Pokegen does not generate OCD-determined* trash bytes by default
by design.

^

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now