Jump to content

PKNX in SX OS not working

Recommended Posts

I am very new to the scene and I need help, I got a switch (used) that was already on sx os, the latest, with firm 11.0.0. My pokemon sword is on patch 1.3.0.

I followed a guide, linked below, to get the PKNX working with my dump of the RomFS and ExeFS, I can see the data in PKNX, save randomized data, close PKNX, then I have the patched folder. Guide says to place it on atmosphere/contents folder, but since I'm on sx os, I don't know what to do with it. I tried to put it into my sx os/contents folder, nothing happened, and put it on sx os/titles, and my game just hangs as soon as I open it. I tried making just a small rando, randomizing only wild pokemon, and it still hangs when I try to open pokemon sword.

Can anyone help me run it randomized?



I could not get it to work in SX OS, the correct folder would be sxos\titles but that just crashes in any way I tried. I ended up switching to Atmosphere. I installed Atmosphere, made a dual boot so I can go back to sx os if I want to, and it just works perfectly on Atmosphere, by default, place it on atmosphere\contents and it loads, no problem.

I tried everything I could think of, I tried ripping my cartridge and modifying that, I tried downloading a few different NSP and XCI versions of either sword or shield, making the simplest modifications, installing in different ways... it would always crash when loading the game with anything under the sxos\titles folder. In case anyone comes here with this problem, I am sorry I don't have better news, but setting up a dual boot with atmosphere is not that hard and very useful anyway.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...