Jump to content

Pokemon Emerald Save is Buggy on Legit Cart and EZ Flash Omega D.E.


Recommended Posts

Posted (edited)

Hello, i have a pokemon emerald save file were i found all pokemon legally (counting out mythical pokemon that i caught injecting events with my r4 , and emulating Gamecube on my pc) .

The problem is that when i inject that save file to my legit cart , the game works but it lags out when i enter buildings and when i change rooms. Another Problem is that in my EZ Flash Omega D.E. it cant save (so i cant keep playing in the battle frontier), in here the game lags out like in the legit cart.

In VBA works just fine. 

I would really like to "fix" this save file because i spent so much time playing to catch all legally.

The .sav is attached.

 

Edit: After a little bit of testing, the laggy part seems to be a GameBoyAdvanceSP thing. I tried reseting the original cart, created a new save and the "buggy" pokemon center is still there. 

In the EZ Flash ODE , i tried as well deleting the .sav and start fresh, and the buggy pokemon center is still there. (With multiple roms)

Tried in 2 SPs with the same results.

The problem is now that i cant save with the .sav attached in the battle frontier in the EZ Flash. But if start a new save , it saves just fine. In my other pokemon .sav (ruby, sapp. , firered , leafgreen) my EZ flash saves with no problem. 

POKEMON_EMER_BPES00.sav

Edited by mrtomrazor
More Info
Link to comment
Share on other sites

There's nothing to fix. If the save works fine on emulators it should work on your EZ Flash as well, I don't see why it wouldn't. Unless there's something wrong with your flashcard setting or if the file/SD card is write protected.

The lag in Pokemon Centers is not a bug, it's a feature of Pokemon Emerald. When you enter the Pokemon Center the game checks for players in the Union Room, even if there's no Wireless Adapter or Link Cable connected.
It's possible to modify the ROM and disable that.

Link to comment
Share on other sites

The problem only happens when i get this text in the Game : "There is already a saved file. Is it okay to overwrite it?" .

How i replicate the problem:
i was playing Castlevania , i saved the game, it works.
I reset the console, i get the message : "Copy game save? ..." in the EZ Flash
I press Ok.
I open Pokemon Emerald , i save , it works fine.
I reset the console , i get "Copy game save? " I press Ok.
I open Pokemon Emerald again, i try to save , i get "There is already a saved file. s it okay to overwrite it?" . I select "Yes". I get an error message like in the picture attached.

IMG_3317.JPEG

Link to comment
Share on other sites

UPDATE: I got it to work consistently by selecting manually in the EZ Flash Save Type : Flash 128k.

It seems that it cant detect with auto that is supposed to save with 128k.

It still bothers me that this doest work as it should , but im glad i got it to work.

thanks for your help.

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...