Jump to content

PkHex not working.


HonxY
 Share

Recommended Posts

Posted (edited)

Currently installed "classic" .NET Versions in the system:
2.0.50727.4927 Service Pack 2
3.0.30729.4926 Service Pack 2
3.5.30729.4926 Service Pack 1
4.0.0.0
4.8.04084

I have .Net 4.8, don't have the pkhex.core.dll in the same folder with .exe.

 

.net checked with https://github.com/jmalarcon/DotNetVersions. which can be found in 

https://docs.microsoft.com/en-us/dotnet/framework/migration-guide/how-to-determine-which-versions-are-installed

 

 

I get this error message.

System.TypeInitializationException: The type initializer for 'PKHeX.WinForms.Main' threw an exception. ---> System.TypeInitializationException: The type initializer for 'PKHeX.Core.GameInfo' threw an exception. ---> System.MissingMethodException: Method not found: '!!0[] System.Array.Empty()'.
   at PKHeX.Core.Util.LoadStringList(String file, String txt)
   at PKHeX.Core.GameLanguage.GetStrings(String ident, String lang, String type)
   at PKHeX.Core.GameStrings..ctor(String l)
   at PKHeX.Core.GameInfo.GetStrings(Int32 index)
   at PKHeX.Core.GameInfo..cctor()
   --- End of inner exception stack trace ---
   at PKHeX.WinForms.Main..cctor()
   --- End of inner exception stack trace ---
   at PKHeX.WinForms.Main.FormLoadInitialSettings(String[] args, Boolean& showChangelog, Boolean& BAKprompt)
   at PKHeX.WinForms.Main..ctor()
   at PKHeX.WinForms.Program.Main()
System.MissingMethodException: Method not found: '!!0[] System.Array.Empty()'.
   at PKHeX.Core.Util.LoadStringList(String file, String txt)
   at PKHeX.WinForms.WinFormsTranslator.GetTranslationFile(String lang)
   at PKHeX.WinForms.WinFormsTranslator.GetContext(String lang)
   at PKHeX.WinForms.ErrorWindow..ctor(String lang)
   at PKHeX.WinForms.ErrorWindow.ShowErrorDialog(String friendlyMessage, Exception ex, Boolean allowContinue)
   at PKHeX.WinForms.Program.CurrentDomain_UnhandledException(Object sender, UnhandledExceptionEventArgs e)

Edited by HonxY
Link to comment
Share on other sites

Posted (edited)
3 minutes ago, HonxY said:

Currently installed "classic" .NET Versions in the system:
2.0.50727.4927 Service Pack 2
3.0.30729.4926 Service Pack 2
3.5.30729.4926 Service Pack 1
4.0.0.0
4.8.04084

I have .Net 4.8, don't have the pkhex.core.dll in the same folder with .exe.

 

.net checked with https://github.com/jmalarcon/DotNetVersions. which can be found in 

https://docs.microsoft.com/en-us/dotnet/framework/migration-guide/how-to-determine-which-versions-are-installed

 

 

I get this error message.

System.TypeInitializationException: The type initializer for 'PKHeX.WinForms.Main' threw an exception. ---> System.TypeInitializationException: The type initializer for 'PKHeX.Core.GameInfo' threw an exception. ---> System.MissingMethodException: Method not found: '!!0[] System.Array.Empty()'.
   at PKHeX.Core.Util.LoadStringList(String file, String txt)
   at PKHeX.Core.GameLanguage.GetStrings(String ident, String lang, String type)
   at PKHeX.Core.GameStrings..ctor(String l)
   at PKHeX.Core.GameInfo.GetStrings(Int32 index)
   at PKHeX.Core.GameInfo..cctor()
   --- End of inner exception stack trace ---
   at PKHeX.WinForms.Main..cctor()
   --- End of inner exception stack trace ---
   at PKHeX.WinForms.Main.FormLoadInitialSettings(String[] args, Boolean& showChangelog, Boolean& BAKprompt)
   at PKHeX.WinForms.Main..ctor()
   at PKHeX.WinForms.Program.Main()
System.MissingMethodException: Method not found: '!!0[] System.Array.Empty()'.
   at PKHeX.Core.Util.LoadStringList(String file, String txt)
   at PKHeX.WinForms.WinFormsTranslator.GetTranslationFile(String lang)
   at PKHeX.WinForms.WinFormsTranslator.GetContext(String lang)
   at PKHeX.WinForms.ErrorWindow..ctor(String lang)
   at PKHeX.WinForms.ErrorWindow.ShowErrorDialog(String friendlyMessage, Exception ex, Boolean allowContinue)
   at PKHeX.WinForms.Program.CurrentDomain_UnhandledException(Object sender, UnhandledExceptionEventArgs e)

+ I opened pkhex before, I am sure its the same version as before.

Edited by HonxY
Link to comment
Share on other sites

Posted (edited)
10 hours ago, Kaphotics said:

Read the stickies. PKHeX requires .NET Framework 4.6 and above

Read the topic. I double checked, as you see it I have 4.8 as said in the topic. I checked regedit too for the version. I also can run other .net framework 4.6 required apps like pkNX. was using PkHex until yesterday. 

 

Edited by HonxY
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...