Jump to content

Help Us With Binary Incompatible Save Issue


Recommended Posts

It's my first topic in this Community, so if I make some mistake just pardon me. To the topic:


Recently I acquired one of those repro cartridges from gen3, everything was passing alright, a lot of fun but when I decided to dump the save I got the "Binary is not compatible save file" issue in PKHeX. What motivates me to do this topic was that I made a research about what is going on here in Pokémon Project and I saw that isn't only me that is getting the same issue, even with a legit cartridge a person got the issue. I want to do my injections with PKHeX, so please help us correcting this trouble!

P.S.: I already made a lot of things like using VBA and importing the sav file, I tried save in-game on MyBoy android app and nothing, they don't recognized the save file, I can't find any save converter. That's all, folks!



Link to comment
Share on other sites

On 8/11/2020 at 8:34 PM, Kaphotics said:

The contents of the attached file, when viewed in a hex editor, are distinctly random.

It's either encrypted, or garbage.

So Kaphotics, my intention is just figure a way out to fix this that what you said... Don't know anything about hex edition, that's the reason I'm asking for a help from community! This is an issue that another ppl are passing through, how can we definitely solution this boring trouble? I humbly think that more than one mind can reach a resolution... Btw, thanks for being the first person to reply me ^_^ 

Link to comment
Share on other sites

@KMSteter_88 it basically means you (and other parties you mentioned) didn't attach a proper save file.

Nothing wrong with PKHeX.

You mentioned you're using a repro cartridge? For your case, the save is stored in the ROM (cause it's a bootleg isn't it. That's how some store saves). Dump the ROM and run it through this program.


Reminder: do not upload the ROM here.

  • Like 1
Link to comment
Share on other sites

1 minute ago, theSLAYER said:

@KMSteter_88 it basically means you didn't attach a proper save file.

Nothing wrong with PKHeX.

Big @theSLAYER thanks for answer me and for all injection events that you have posted! I know that PKHeX is alright, mine is working fine, my worries is how to do the save be correctly read by PKHeX and how can I put the save in proper way to reinject it successfully in the cartridge. Can you explain me what is the right process to attach to be recognizable by PKHeX? I did the post think in all members that already passed trough this weirdness haha... Hugs

Link to comment
Share on other sites

No worries. To explain what Kaphotics said to you (which I assume went over your head).

hex editor: a piece of software that can view the raw data of any file. (all files are made up of raw data)

When the save you uploaded was viewed using a hex editor, it is completely garbled, which should not be the case for a gen 3 save file.
Which means (a) the save is encrypted or (b) the save is garbage.

PKHeX deals with console decrypted saves (and not garbage), which is why it will neither load (a) nor (b).

Hence he was presumably saying (without actually stating it) to use a proper save file. I guess people who have some technical knowledge would logically reach that conclusion, but maybe you weren't one of these people hence you didn't see it.
[Contents uploaded are garbage, hence PKHeX won't load it -> So grab a proper save, and PKHeX will load it]

Also, as for VBA, don't use state saves and export save battery file (or something close to that).
As for your Myboy emulator, no idea what the issue is. Make sure you save in-game, and if you have questions, load that save here.

Link to comment
Share on other sites

  • 1 year later...
5 hours ago, maxvgc said:

I was getting the same error with myboy and the fix was going to advanced settings and changing the cartridge save type from automatic to eeprom

That error message covers a lot of different user issues. It generally means 'you're using the wrong file with PKHeX'. That's the only thing in common between you and the OP.

In the OP's case, it's because they were trying to extract a save the mainstream route while using a repro cart. (Repro cart needs different ways to extract saves).

In your case, it is because your save size isn't configured properly in your emulator settings.

Your solution would not work for the OP, and the solution to OP's problem would not work for you.

Still, this is rather out there, but I hope people with MyBoy settings issues similar to yours would see your post and resolve the issue on their own. :3

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...