Jump to content
Sign in to follow this  
Earthworm Len

Need desperate help fixing my game's coordinates (ORAS)

Recommended Posts

Posted (edited)

Hi, so, I was stuck in the Elite Four after loading my save because I backed up my save in the wrong place so I edited my coordinates so I'd end up in Rustboro (image attatched). When I went to play, though, all I was met with was a black screen, or a "hang". I also stupidly did not have another backup for this save file, so I'm scared my save's been pretty much bricked. Any advice, or even someone fixing the attached file would be extremely appreciated, I've had this file for around four years and I wouldn't know what to do with myself if my mistake ruined it. 

edited_trainer_data.png

main

Edited by Earthworm Len

Share this post


Link to post
Share on other sites

You have no backup at all? check your 3ds checkpoint/jksv that you used to backup save, and check your pkhex bak folder.

Share this post


Link to post
Share on other sites

I don't know what you did, but my usual fix isn't working.
I'm guessing you did more than a coordinate change..

I may be able to stitch parts of your save into one of mine, so sit tight.

 

edit: This should work for you. Certainly works for me.
main

  • Like 1

Share this post


Link to post
Share on other sites
7 hours ago, theSLAYER said:

I don't know what you did, but my usual fix isn't working.
I'm guessing you did more than a coordinate change..

I may be able to stitch parts of your save into one of mine, so sit tight.

 

edit: This should work for you. Certainly works for me.
main

Oh my goodness my save works now! Thank you so much!

Share this post


Link to post
Share on other sites

It's your save, for the most part.

What isn't yours (with reference to this) :
1. Situation block
2. Field move model save block

Typically I'll import these from another save (with that other save still functionally loading). These blocks contains map ID, coordinate data and overworld NPC data, and such an import usually resolves the issue, however oddly your save still wouldn't work. By chance, I found out that something in your MyStatus block is causing the save to not load, thus:

3. MyStatus block

I replaced that block, with the donor being a female save. Afterwards, I replaced it with your OT, Trainer ID/Secret ID & Money to match your original save.

After I the import blocks via hex editing, I load the save into PKHeX and then save it there; this fixes the checksums.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...