Jump to content

Pokemon Sapphire corrupted save - can it be repaired?


yojc
 Share

Recommended Posts

Hi,

I was playing Sapphire on my GBA with Everdrive X5, but right near the end of the game (IIRC right after the battle with Wallace) the save got corrupted somehow. I was getting the "The save file has been deleted..." message, and that's it.

I was able to copy the same from Everdrive to my PC, and the save doesn't work in VBA either... however, PKHeX loads it with no issues. With that said, veryfing this save in PKHex gives a message "Block 09 @ 02000 invalid.". Exporting the save seems to fix that, but it still doesn't work on VBA nor Everdrive.

I'd assume that since the save seems to be fine in PKHeX with all data intact, it should be able to repair it somehow... but how? Any ideas?

Thanks in advance!

Pokemon - Sapphire Version (USA, Europe) (Rev 2).dat

Edited by yojc
Link to comment
Share on other sites

Each part of the save has a checksum, and that sector checksum is incorrect. (as noted by what you posted PKHeX said).

the solution for that is to really, save in PKHeX, cause PKHeX recalculates the checksums.

I also copied Block B of your save over Block A. (Typically, saves keep a duplicate as a backup.)

I don't fully recall, but your Block A looked mostly empty, so thus I duplicated Block B over Block A,
then used PKHeX to fix the checksums.

I confirmed VBA can load the savem, then I sent it to you.

What caused the corruption? No clue, maybe having too many cheat codes activated or something.
It is known that too many cheat codes active can mess with the save.

  • Like 1
Link to comment
Share on other sites

  • 1 year later...

Hello there I have a similar issue with my Sapphire version save. I was trying to make a trade between my Sapphire and Ruby versions and one of the gameboy froze in the process of transferring the pokemon I turned both gameboys off tried trading again and the gameboy froze again so I kept retrying and on the next reset my Sapphire save was gone and it gave me the"save file has been deleted" message. Am I still able to recover my save file? :(

POKEMON SAPP_2021.06.22-14.19.03.sav

Link to comment
Share on other sites

51 minutes ago, LuisKyouma said:

I just tried it on my cartridge and it works!!! Did you have to do anything to the sav file?

Loaded it into PKHeX, and it could view the file. Then I saved, and loaded it into my emulator, and saved twice in it.
Besides that process, nothing.

38 minutes ago, LuisKyouma said:

Thank you so much! Have a great rest of your day! 🤩👊🙏🙏

you too.

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...