Jump to content

[Gen 4] PKHeX is just broken


Recommended Posts

Hey o/

Sorry i couldn't find a better title, sorry for that. But it's really broken since well it just doesn't save any edit or anything anymore.

Today, I wanted to transfer a Gen 3 Bulbasaur to Gen 4. I took a Bulbasaur from my Fire Red, and moved it to my Soul Silver.
I move it (i just do nothing else)

I save the edits.

I launch Desmume. Nothing. No edit pops. I close the game. I recheck the save, the edits are still shown with PKHeX.

I tried to save it to a new file rather than replacing. Doesn't work.
I'm sure it's the correct save, I'm sure to save etc.

Just it doesn't do anything.

 

Thanks o/

Link to post
Share on other sites

No doubt for that, I'm more than used to dealing with save stuff.
It can be either the emulator or Pkhex, but i've no state, no other file. Nothing to make it like this.

 

Gonna try on my other pc with an older pkhex / different emulator.

 

Edit : Doing a simple edit before doing the import works. If I ONLY do the import of an older file, it's simply ignored

Edited by Vladcik
Link to post
Share on other sites

Was able to redo it again. I wanted to move a Chatot for my RNG.

1. Opened my Soul Silver and my Diamond.

2. Moved my Chatot from my Diamond save (party) to my Soul Silver save (box)

3. Saved

4. Loaded my Soul Silver = no change.

5. Loaded my Soul SIlver on PKHeX = changes are here.

And the Bulbasaur earlier was done from a file.

Link to post
Share on other sites

Something similar has been reported recently-ish (except the other way around.)

Leads me to believe there could be some issue with active box block detection happening under certain conditions.

Link to post
Share on other sites

What I know is that active general and storage blocks don't always necessarily follow each other, so if something in the logic changed which causes it to assume that active blocks follow each other, it could result in the backup block being loaded instead of the active one (idk how it works in newer games, this sounds like the kind of thing that could be correct for newer games but not correct for older games, and that would be easily overlooked.)

Link to post
Share on other sites

Well, things had started behaving a bit more for me with the last update to PKHeX, but that might have been less to do with the update and more that I wasn't shuffling Pokémon around as much once I got out of Box 1 (where I left some spots intentionally empty for reasons).

That being said, though, I did recently run into issues with event constants with leads me to believe there are definitely some problems with Gen 4 support at the moment. I haven't tried updating to the most recent version yet so I don't know if things got better or more broken (especially since there's no Gen 4 changes or bugfixes listed)

Edited by NekoSabrina
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...