Jump to content
Irina

Sword and Shield save problems

Recommended Posts

Whenever I edit in a new Pokemon and save the file, it doesn't actually save. As when I reopen the file on PKHeX, the Pokemon that I just edit in is not there.
Is there a way to fix or prevent this?

Share this post


Link to post
Share on other sites
7 minutes ago, theSLAYER said:

Sorry, I gotta ask.

Did you "set" the mon into the save?
image.png

Did you save the save file?
image.png

Yes sir, I did all that. And when I'm done I click on quit. Then when I reopen, the mons that I have saved before are not there.

Share this post


Link to post
Share on other sites
1 minute ago, theSLAYER said:

what version of PKHeX are you using, and on Mac or Windows?

My edits loads just fine.

  Reveal hidden contents

Before
image.png

After, I reloaded my save.
image.png


I'm on the latest versionimage.png

I too am on the latest version. Sometimes when I edit in one Pokemon, save then quit, they are there. However when I do bulk at a time (I did around 30; all different and legally available in Sword/Shield; no error marks shows up on any of the Pokemon), they don't seem to appear when I reopen.

Share this post


Link to post
Share on other sites
4 minutes ago, Irina said:

However when I do bulk at a time (I did around 30; all different and legally available in Sword/Shield; no error marks shows up on any of the Pokemon)

I've imported by bulk before, and it works fine too.
 

Spoiler

This is a reloaded save using bulk importimage.png
 

 

I used this, and hit 'Yes'
image.pngimage.png

Maybe it's the method of bulk importing.
How do you bulk import?

Share this post


Link to post
Share on other sites
2 minutes ago, theSLAYER said:

I've imported by bulk before, and it works fine too.
 

  Reveal hidden contents

This is a reloaded save using bulk importimage.png
 

 

I used this, and hit 'Yes'
image.pngimage.png

Maybe it's the method of bulk importing.
How do you bulk import?

I manually create the mons from scratch and save them. It doesn't seems to allow me to edit them in a bulk. Right now, due to this problem I am having to create one at a time, close, reopen, repeat.

Share this post


Link to post
Share on other sites
2 minutes ago, Irina said:

I manually create the mons from scratch and save them. It doesn't seems to allow me to edit them in a bulk. Right now, due to this problem I am having to create one at a time, close, reopen, repeat.

Your "bulk" is editing them in one by one?

Spoiler

I've added these in 1 by 1 (the bottom row), by viewing same mons on the top row, adding 1 level, them setting them below.
This is a reloaded save.

image.png

Are you creating mons totally from scratch? or are you viewing an existing mons then making edits?

I couldn't replicate the steps nor the error you're encountering.
 

Share this post


Link to post
Share on other sites
3 minutes ago, theSLAYER said:

Your "bulk" is editing them in one by one?

  Reveal hidden contents

I've added these in 1 by 1 (the bottom row), by viewing same mons on the top row, adding 1 level, them setting them below.
This is a reloaded save.

image.png

Are you creating mons totally from scratch? or are you viewing an existing mons then making edits?

I couldn't replicate the steps nor the error you're encountering.
 

Yes, I was mass creating them totally from scratch (not from pre-existing mons). However, as it does not seem to save them (even though I hit save after quitting), I am to create one at a time, close, reopen, and repeat.

Share this post


Link to post
Share on other sites
2 minutes ago, Irina said:

Yes, I was mass creating them totally from scratch (not from pre-existing mons). However, as it does not seem to save them (even though I hit save after quitting), I am to create one at a time, close, reopen, and repeat.

I just tried adding entries by creating them from scratch, and they were stored in the save too.

You probably should delete your PKHeX then redownload. Can't think of any other solution cause only you're experiencing it and I can't replicate it.

Share this post


Link to post
Share on other sites
12 minutes ago, theSLAYER said:

I just tried adding entries by creating them from scratch, and they were stored in the save too.

You probably should delete your PKHeX then redownload. Can't think of any other solution cause only you're experiencing it and I can't replicate it.

I will try and get back to you after testing. For now, thank you for taking your time dealing with me.

  • Like 1

Share this post


Link to post
Share on other sites
1 minute ago, Irina said:

I will try and get back to you after testing. For now, thank you for taking your time dealing with me.

No worries, I'll like errors to get ironed out too

Share this post


Link to post
Share on other sites

Hi,

Same problem here. Windows user, I've been using PkHeX for a long time already (almost since release, I'm also an advanced PC user and I try to be careful with what I do) and I noticed this problem since the SWSH release. Pokémon register in the Pokédex when you set them, but they might not appear in boxes when I reload the save file. Items set always fine, however. Since I've now become paranoid while editing/creating Pokémon and I save now after every edit and reload the save file to see if everything worked fine, I can't tell you exactly when this error appears, but I can confirm I've experienced the same problem as OP. It might be after editing several Pokémon without saving and then saving the save file later, one of the edits must cause that all later edits don't save, because saving individually after every edit seems to avoid the problem.

Share this post


Link to post
Share on other sites

@walppeople Use the latest version, provide exact steps that cause the mons to not show up in PKHeX.

Granted, I've read that people have issue making mons appear in the game, I've never had any of those issues and couldn't replicate the issue. (unable to have correct presentation in game isn't same as not appearing in PKHeX)
So it'll be great if you could give step by step instructions (and maybe screenshots) of your issues, so that we can try to recreate the issue.
If we can't recreate it, we cannot fix it.

Share this post


Link to post
Share on other sites
1 hour ago, theSLAYER said:

No worries, I'll like errors to get ironed out too

After re-downloading and testing, it seems like the problem still occurs for me.

Share this post


Link to post
Share on other sites

It's weird because if I just randomly create mons rapidly (regardless of legal or not) then save, the problem doesn't occur. However, it only seems to happen when I go on for not saving (on PKHeX) for a while (while creating mons), then save, reopen, the problem seems to occur.

Share this post


Link to post
Share on other sites
3 minutes ago, Irina said:

After re-downloading and testing, it seems like the problem still occurs for me.

how odd.
Have exact step-by-steps + images in a spoiler, and hopefully we can recreate it following the steps

Share this post


Link to post
Share on other sites
3 minutes ago, theSLAYER said:

how odd.
Have exact step-by-steps + images in a spoiler, and hopefully we can recreate it following the steps

Maybe it has to do with not saving for a while? Read full explanation of what I mean above your most recent comment.

Share this post


Link to post
Share on other sites
40 minutes ago, theSLAYER said:

Use the latest version

I am, I always use the latest version available. It's been happening with all releases since the SWSH release, so it's either a problem consequence of the new code added (can't help there, though) or a problem which already was there and manifests now in SWSH, which would be weird, actually.

40 minutes ago, theSLAYER said:

If we can't recreate it, we cannot fix it.

I'll do my best to recreate it and post the steps. You guys are great, I'll do my best to help. It might take a couple of days, though, I'm a bit busy at the moment.

 

EDIT: " unable to have correct presentation in game isn't same as not appearing in PKHeX)".  --- They don't show neither in-game in the boxes nor in the boxes in PkHeX, they just register in the Pokédex if it was a new Pokémon but disappear when you close PkHeX, regardless of saving the file before closing the app, which means they didn't set properly. Like I said, I'll try to recreate the error.

Edited by walppeople
Added some more info.
  • Like 1

Share this post


Link to post
Share on other sites
2 minutes ago, Irina said:

Maybe it has to do with not saving for a while? Read full explanation of what I mean above your most recent comment.

I saw what you said, but once again: without a step by step guide, it's hard to replicate the issue.

We gotta be doing exactly what you're doing.

 

In the mean time, I can try the "not saving for a while" thing, but I honestly don't think that'll be any different.

Just now, walppeople said:

I am, I always use the latest version available.

There's sometimes hotfixes to issues, where the hotfix is uploaded onto the site, and PKHeX won't prompt you to update.

So you may think you're on the latest, but if you don't check the site, you really might not be. Thus I'm just saying :)

Share this post


Link to post
Share on other sites
1 minute ago, theSLAYER said:

I saw what you said, but once again: without a step by step guide, it's hard to replicate the issue.

We gotta be doing exactly what you're doing.

 

In the mean time, I can try the "not saving for a while" thing, but I honestly don't think that'll be any different.

Alright, thank you. I will try to post in more detail "guide" later today or tomorrow

  • Like 1

Share this post


Link to post
Share on other sites
4 minutes ago, theSLAYER said:

There's sometimes hotfixes to issues, where the hotfix is uploaded onto the site, and PKHeX won't prompt you to update.


So you may think you're on the latest, but if you don't check the site, you really might not be. Thus I'm just saying :)

I am, I am. I almost never update after an app prompt, I check the website myself.

By the way, I just edited my last post with some extra info. Just like Irina, I'll try to contribute and recreate the problem as soon as possible.

Share this post


Link to post
Share on other sites

While PKHeX has had legality issues since the new update, and I read that some people add a mon but it instead shows as lv 0.
Despite that, I've never had any issues of that sort. I was able to wipe my PC and fully inject various mons (for screenshots), so I have not encountered your issues, and have not been able to recreate them.

With that said, I am not denouncing any of the experiences either one of you had. Perhaps you guys adds mons differently from me.
 By chance, your method happens to encounter the issue, so when you continue your method, you continue to encounter the issue.
As we're different people, I deviate from your method and unable to think up your method, thus never encounter it.

Thus, the only solution really was you guys to provide a step-by-step, so that I can try to do it your way, in an attempt to recreate the issue.

  • Thanks 1

Share this post


Link to post
Share on other sites

@walppeople @Irina

Just wondering, did you manage to transfer the save successfully into the game (after one of the save attempt worked)? I‘m also experiencing kind of the same error, where the export does not include my recent changes, and yes I double-checked every step... but in-game  it just loads the previous one...

Could changing the Trainer-ID has something to do with it?

Share this post


Link to post
Share on other sites
Just now, iChaos92 said:

@walppeople @Irina

Just wondering, did you manage to transfer the save successfully into the game (after one of the save attempt worked)? I‘m also experiencing kind of the same error, where the export does not include my recent changes, and yes I double-checked every step... but in-game  it just loads the previous one...

Could changing the Trainer-ID has something to do with it?

I transferred the save without errors, it loaded properly and then I realised the Pokémon weren't there. I know it was the edited save because the new Pokémon were now registered in the Pokédex (I wanted to have all three starters but I hadn't seen them all yet, now they were in the Pokédex). Then I checked that same file in PkHeX (the file I injected, I didn't dump it again nor edited it before I opened it again) and they weren't there in the boxes either.

I didn't mess with trainer ID or anything.

59 minutes ago, theSLAYER said:

While PKHeX has had legality issues since the new update, and I read that some people add a mon but it instead shows as lv 0.
Despite that, I've never had any issues of that sort. I was able to wipe my PC and fully inject various mons (for screenshots), so I have not encountered your issues, and have not been able to recreate them.

With that said, I am not denouncing any of the experiences either one of you had. Perhaps you guys adds mons differently from me.
 By chance, your method happens to encounter the issue, so when you continue your method, you continue to encounter the issue.
As we're different people, I deviate from your method and unable to think up your method, thus never encounter it.

Thus, the only solution really was you guys to provide a step-by-step, so that I can try to do it your way, in an attempt to recreate the issue.

I don't make Pokémon from scratch, I take an existing Pokémon , set it in another slot and edit it there. I change species, met location, attacks etc. and set it when it's finally legal. Sometimes it saves properly, sometimes it doesn't, apparently. Probably not relevant, but I only edit and set legal Pokémon, I don't want them if they don't pass the legality check (I'm aware PkHeX still doesn't recognize all in-game caught Pokémon from SWSH as legal, I have some legit Pokémon caught in-game which still don't pass the test, but I know you guys are working on it).

I've never found this level 0 issue.

I don't doubt you believe us but you just can't recreate the issue. I understand it, I'd do the same. I'll look into it and come back to you.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...