Jump to content
loonix200

Pokedex Displays Shiny Version Of Transfered Pokemon

Recommended Posts

Hello friends,
I am new to PKHeX so I will try to keep it short and simple but forgive me if I go into too much detail. I come here after trying everything for hours.

I played Pokemon Emerald on VBA using a normal ROM and completed a Living Dex on it. Recently I got a new PC so I downloaded Citra and completed Pokemon X and Alpha Sapphire on it. So I decided to get a shiny charm for shiny hunting.

In order to complete the National Dex, I decided to legitimately own every single pokemon in it. I couldn't trade because of emulator, so I decided to legally catch every Pokemon. I caught every single Pokemon that can be caught in Alpha Sapphire. Being new to PKHeX I had no clue how to use it and not a lot of "Simple" guides I could find that were solely for transfering Pokemon. Most of the guides were for making a new pokemon and all that cheating stuff.

I opened two windows of PKHeX and in one of them, loaded my Emerald .sav file. In the other one, I loaded my Pokemon X save file (.main). I manually dragged every single pokemon from one window to the other, one tile at a time. Finally I had Boxes 1-6 filled with my Original Pokemon from Pokemon X. Boxes 7-12ish had my Pokemon transfered from Emerald by simple drag and drop. I did the same for Alpha Sapphire. Basically I had all the Pokemon I LEGALLY CAUGHT in each game, now in one game. Here's where the problem began:

When I Open Pokemon X's pokedex, I saw that my Grovyle was oddly colored. I opened its summary to see that its Shiny sprite is being displayed and there is no option to display his normal sprite. This was weird because the game showed I had caught "001" normal forms and "000" shiny forms which is correct. So a lot of Pokemon in my National Dex turned out to be appearing shiny when I havent seen their shiny form ever in any game or obtained them.

Keep in mind all of the Pokemon in their respective form were caught legitimately using normal catching methods. No cheats no 3rd party programs involved. PKHeX was ONLY used to transfer over 150 Pokemon to one single game. Can anyone please help why this is happening and how I can fix this? Please note the Pokemon appear normal in boxes and everywhere else. Just in National Dex, they appear Shiny and no option to show their normal sprite.
I actually have an ACTUAL shiny caught (legal as well). I opened it to check and apparently that one has normal sprite and shiny sprite and I can choose to display either.

Would be very glad if you could help me out here. I dont have a lot of info about the program. I am willing to provide any info or files that you may require, from Save game files to Screenshots.
In the images attached below, you can see the Grovyle as an example (SO many pokemon are affected) and in other image you can see the ACTUAL Shiny Makuhita I have, and the fact that I can view his normal Skin when I cant do the same with Grovyle.
I'll try to reply as fast as possible so please don't give up on the topic if I dont reply in time, ty!

TLDR: Legitimately caught pokemon when transfered to Pokemon X using drag and drop of PKHeX, appear shiny in dex without normal sprite available. 

Grovyle 1.png

Grovyle in Box.png

Legit Shiny Example.png

No Other Sprite Grovyle.png

Share this post


Link to post
Share on other sites
Guest

Which version of PKHeX are you using? It seems that it may have applied the wrong flags for pokédex displayed form when you transferred your Pokémon, while properly marking the non-shiny form as seen and leaving the shiny form as unseen.

Share this post


Link to post
Share on other sites

@loonix200 is this option checked?
 

image.png


I just dragged a Bulbasaur over from Gen 3, and it was registered as both Seen and Owned (no shiny icon)

Spoiler

image.pngimage.png

What version of PKHeX are you on? I'm on 20190919, and as you can see, the Bulbasaur transferred up just fine.
 

 

5 hours ago, loonix200 said:

appear shiny in dex without normal sprite available. 

If I'm not mistaken the phenomenon described happens when something is Owned but not Seen.

Spoiler

Reproducing the phenomenon:

image.png

While looking at your Grovyle image, that doesn't fully seem to be the case, it's probably related to Seen/Caught flags.

Share this post


Link to post
Share on other sites

@Ammako Hello, ty for replying and sorry for late reply. I am using 19.9.19.0 which was the latest version available when I downloaded it a while ago. No files have been changed or messed with. I've only used the executable file.

@theSLAYER Hello, thanks for replying. I am using 19.9.19.0 version as stated above. I can update it if required but I don't believe that should be the issue. The "Modify Pokedex" option in settings is ENABLED. 
I apologize in advance for any inconvenience but from the earlier part of your statement it appears that I can't see the normal skin because I transferred it therefore it registers as "Caught" but its not seen in the wild or evolved in any form from my bench so it doesnt register as "seen" (At least that's how I assume it works?). But the issue still stands, why is it displaying the shiny sprite then, considering I haven't seen those either.

And once again I'm really sorry but I dont know how to use PKHeX very well. In your second screenshot, you have "Pokedex Editor (XY)" open that displays the Pokemon's "Seen/Caught/Display" and other info. However I dont know how to open that or check that.
In the end I tried to understand your reply as much as I could but I couldnt figure out a solution to the Seen/Caught flags that you mention.

So in the end, I'm answering your questions to the best of my extent hoping I can find an answer. Please keep in mind the problem applies to MULTIPLE pokemon but not every Pokemon. I still have the backup saves so if I have to transfer the Pokemon from Emerald and Alpha Sapphire again, then I have no issue doing that. It's time consuming but if it leads to an easier solution, you can consider this an option.
My only purpose to use PKHeX was to transfer pokemon and I've only done that by opening two saves in two windows and dragging from left box to the right box. That's all. Thanks in advance! Screenshots of transfer Procedure are attached below.

In screenshot one, I show the two windows with The Grovyle still in its original Emerald Save. In 2nd, I drag the Grovyle which obviously can't be seen due to screenshot limitations. In the third screenshot, I've dropped the Grovyle into Pokemon X Save and clicked View to show that it is legal and has everything set up just fine!

TLDR: Version is 19.9.19.0. Modify Pokedex option is enabled. Can't figure out a solution.

Transfer 1.png

Transfer 2.png

Transfer 3.png

 

EDIT: Worth mentioning that I did take the Grovyle into random battle in the wild in order to trigger the "seen" flag according to my understandings but it did not help at all.

Edited by loonix200
Additional Info

Share this post


Link to post
Share on other sites
27 minutes ago, loonix200 said:

Worth mentioning that I did take the Grovyle into random battle in the wild in order to trigger the "seen" flag according to my understandings but it did not help at all.

that seems to be the problem. When it is not registered as both "seen" or "caught" upon import, and you manually triggered the seen (with what you described above), that is what happens.

Also in the first example above (which did not show it as shiny), I didn't edit the seen/caught flags. I'm merely showing the state of the flags after the import.
 

I recommend you dump the mons into folders (on your PC), then try to import from the box again, while the modify Pokedex is checked. There was a similar thread from a few weeks ago, which more or less had the same issue.

The user was having issues, and following these steps, I was able to get the dex to function properly:

On 9/23/2019 at 9:52 AM, theSLAYER said:

ON Modify Pokedex, THEN IMPORT the Pokemon data.

When you do this, they will appear as SEEN AND CAUGHT in your Pokedex.

 

Share this post


Link to post
Share on other sites
58 minutes ago, theSLAYER said:

that seems to be the problem. When it is not registered as both "seen" or "caught" upon import, and you manually triggered the seen (with what you described above), that is what happens.

Just making sure you know this: The problem is with multiple Pokemon. I took him out of the box and into battle AFTER your reply to see if I can trigger the "Seen" flag. So that seemed to have no effect.

As for the folder method, like I mentioned multiple times, I'm not very familiar how to use the app to its full extent. I have about 300+ Pokemon needed to be transferred. Here's what I did with my lack of knowledge lol:
1- Opened the Pokemon X save file and right clicked the "Box" tab. Delete>Clear. Cleared each box one by one, but only the ones I imported, my original Pokemon from Pokemon X were still there and I didn't delete considering they didn't have any issue.
2- I opened my Emerald and Alpha Sapphire saves one by one and went to Tools>Data>Dump Boxes, which exported my Pokemon as .pk3 and .pk6 in the pkmdb folder.
I then went to Tools>Data>Load Boxes in Pokemon X save file to load the Pokemon in Pokemon X boxes.

3- I saved the file by File>Export SAV>Export Main.

During ALL this, the Modify Pokedex was ENABLED. This did not solve the issue.

Please remember that I used the save file that already had the shiny issue and only CLEARED the boxes, and replaced the Pokemon using the three steps listed above. I have backup of my save file BEFORE doing this procedure and an old backup of Pokemon X Save BEFORE transferring Pokemon over to it. However I would like to not have to return to that save considering I recently mentioned this issue and ended up collecting a lot of Pokemon in X that would not be present in the old save.
IF the issue gets solved however, its possible to just transfer the newly caught Pokemon from my current save to the old save without any issues and then continue using the old save. The reason I'm stating this is because if for some reason its impossible to solve the issue once my pokedex has been messed with whatever these flag issues are, I can STILL resort to my old save and just transfer my new pokemon to it later if I find a solution. 
I'm only trying to state all this so you have an easier time finding a solution.

Sorry for inconvenience again appreciate any sort of help!

IMPORTANT EDIT: I loaded the old .main file of Pokemon X which I saved as backup before transfer. Remember that this is the file that has NEVER been put into PKHeX and has no pokemon from Emerald or ORAS. Therefore, it has never seen Grovyle or any of those pokemon for the matter.
I opened it and went to Tools>Data>Load Boxes and imported the pkmdb folder. Clear subsequent boxes dialog, I pressed No. Modify .pk dialog, I pressed Yes. I saved it and tested the new file and turns out:
MOST pokemon that were transferred are now appearing shiny. Keep in mind "Modify Pokedex" is enabled in settings. Previously Mudkip was shiny, Marshtomp was normal and Swampert was again shiny, despite them being from the same game/save file. NOW even marshtomp is shiny. There are still Pokemon that are not displayed Shiny but I thought it was interesting enough to mention

Edited by loonix200
Additional Info

Share this post


Link to post
Share on other sites

You ask for a "solution", but in reality there isn't anything wrong with PKHeX. :/
And I know that the issue is not with PKHeX, because I'm able to import my files just fine.

The best I could do for you, is give you a few images to follow, and you should try to follow em.
If they still fail you, then I'll be equally lost as you.

Read the text in the spoiler below thoroughly, and follow the images as closely as possible

Spoiler

1. Settings on my PKHeX. Since these settings work for me, I advise you follow them too.

1 pkhex settings.PNG


2. For this demonstration, I purposefully wiped out my Pokédex, with nothing seen or caught besides a Shiny Genesect.
This way, you know my final results weren't because oh they were already in your dex.
2 in dex.png


3. Here is me performing a fresh dump of my non-shiny living dex from an Emerald save file.

3 emerald dumping.png

4. and here is what it looks like in the folder
4. files in emerald.PNG


5. Now importing the files into my Gen 6 save
4 importing files.png


6. Maybe this option is relevant? I chose "Yes"

5 maybe relevant.png
 

7. As you can see, my Bulbasaur isn't shiny.6 in dex.png

I also checked through my other entries and they weren't shiny too. Surely you don't expect me to make a gif of 386 Pokemon to prove the point?  😜


I hope this will be of some help to you :)

Share this post


Link to post
Share on other sites

It's fine, at least you tried to help. In the end, I have the same settings as you, and did exactly the steps you did. I did manage to open the Pokedex Editor which I didnt know how to do before because I was only using the program for drag and drop.

There are Seen, Owned and Displayed Windows inside there. A lot of transferred Pokemon were set at "Shiny Male" in the Displayed section for no reason. Even pokemon that were EXCLUSIVELY found as female and don't have a male version at all, had Shiny Male checked and Greyed out (Obviously only Female and Shiny Female are not greyed out) Funny how a greyed out option was checked.
I manually went through 700 Pokemon and set them to Male or Female. This fixed a LOT of Pokemon, but some of them that I have not obtained but only seen, still display as Shiny Male when set to Male. 
You can close this now if you want. My only hope is to complete a Living Dex and then maybe setting them all as "Displayed Male" will work. Until then, I dont fucking know man I wasted so much time and kinda tired of this 😓

Share this post


Link to post
Share on other sites

As an experiment, I did the following if it helps you collect any info:


1- ALL the Pokemon that I caught in Pokemon X were obviously displayed correctly. So I dumped the boxes that contained all those pokemon into a "Test" folder.
2- I then deleted every pokemon from every box.
3- I opened Pokedex Editor and clicked Modify and "Seen None".
4- I cleared my part outside of the one Zangoose I had.

5- I set Zangoose as Seen: Male, Owned: Native(Kalos), Displayed: Male, Language: English.
6- I saved the file and started the game. I had only one Pokemon in National Dex, the rest was clean

7- Zangoose was perfectly fine.
8- I, then Loaded the Boxes from the "TEST" folder which were all the Pokemon dumped from the SAME file.
9- Now I had all the Pokemon X mons back in their boxes that were caught locally in this exact game.
10- Modify Pokedex was Enabled.

11- I saved the file and loaded the game.
12- EVERY SINGLE Pokemon X pokemon (Which were previously all normal) were now displayed as Shiny. All of them.

Found it interesting so I thought I should share.

EDIT: Experiment 2:
1- I cleared all the boxes and all the pokedex again.

2- Modify> Complete Pokedex.

3- Saved and ran the game.
4- Pokedex was complete and every Pokemon was showing normally EXCEPT a select few..

Remember when I said I manually set every Pokemon from Shiny Male to Male in my actual save? And there were still a few Pokemon displayed Shiny after "Displayed: Male" was selected? Those are the exact Pokemon that are still appearing Shiny even when I didnt use any of my Pokemon, just the Complete Pokedex option. One example is Venusaur. PKHeX Says "Displayed: Male" yet it appears shiny.

Sorry Im not trying to extend this topic anymore but I found some stuff interesting and wanted to share. My brain is way too small for this. I'm just a casual player who wanted to complete a legal living dex without any cheats ._.

Edited by loonix200

Share this post


Link to post
Share on other sites

Here is my case: I did use pkhex to transfer pokemon from my pokemon Y save to my pokemon X save, and when i look at my X's pokedex, suddenly the default spite become of a shiny (altho i never have seen or caught that specie 's shiny yet) - example: the image on charizard entry become of a black charizad. When i acess the entry and check the spite, it will show that i didn't actually have the shiny spite registered (since i never have a shiny charizard ever) and only after that the pokedex display the normal spite without showing a shiny spite. If i want my pokedex to back to normal i will have to check the spite of all the pokedex entry again. 

Share this post


Link to post
Share on other sites
Guest

Can you import your pokémon via drag and drop instead of loading boxes, and see if this avoids the issue?

Share this post


Link to post
Share on other sites
Just now, Ammako said:

Can you import your pokémon via drag and drop instead of loading boxes, and see if this avoids the issue?

@Ammako I didn't even know the box system existed before. When I posted the issue, I mentioned that I was using drag and drop exclusively. Only after I was suggested to dump boxes did I learn to do that. So my issue remains in either case.

Also what @squall1989 mentioned, happened to my Charizard as well after I manually set all Pokemon to Displayed: Male instead of Shiny Male. It would show Shiny Female, but when I opened it and switched to the ACTUAL female version, the shiny one would immediately turn back to what it is supposed to be, Normal Male. 
I didnt mention this because my original problem was much bigger and this was insignificant to me at the time and I can live with that.

Share this post


Link to post
Share on other sites
Guest

Would you mind uploading the original save from before you did any of the transferring?

Share this post


Link to post
Share on other sites

I just test it just now:

Case 1: i drag and drop my normal charizard from my Y save file to a new X save file which is just get the starter and pokedex => The charizard dex entry is normal, work perfectly.

Case 2: i export my normal charmelion and my normal Charizard from my Y save file to the new X save file that i mention in case 1 (it is used to test case 1 first, so it already have the charizard entry saved) => the charizard entry stay fine, but the new charmelion dex entry's spite become of a shiny one.

About the file: i will make a new file and begin the test again, will attach later.

Share this post


Link to post
Share on other sites

@Ammako

This is the original Pokemon X Save before any transfer:

main

This is the original Pokemon Alpha Sapphire Save before any transfer:

main

This is the original Emerald Save file before any transfer:

[VBA]1986 - Pokemon Emerald (U)(TrashMan).sav

Please rename the last one according to whatever is required by you to load it. I used VBA-M to save Emerald. And Citra to save X and Alpha Sapphire.

PKHeX was downloaded from here:

https://projectpokemon.org/home/files/file/1-pkhex/

Edited by loonix200

Share this post


Link to post
Share on other sites
Guest

For what it's worth, I can reproduce the issue.

It doesn't matter whether I drag and drop or use the import boxes function, the end result is the same.

PKHeX seems to not be setting the "displayed" flag, only the "Seen" flag.

Edited by Guest

Share this post


Link to post
Share on other sites

Attach file:

(1) main - Y save file: the file i transfer pokemon from.

(2) main - X save file before transfer: the new X save file, save after get fennekin as starter and get pokedex.

(3) main - X after transfer using drag and drop: file (2), after transfer a few pokemon using drag and drop, i also compress the pokemon file that used in the transfer - Pokemon transfer with drag and drop.rar

(4) main - X after load boxes folder: file (2). after import box all pokemon export from file (1), i also compress the folder with winrar and attach in - PKM folder.rar

 

main - Y save file main - X save file before transfer main - X after transfer using drag and drop main - X after load boxes folder PKM folder.rar Pokemon transfer with drag and drop.rar

Share this post


Link to post
Share on other sites
2 minutes ago, Ammako said:

For what it's worth, I can reproduce the issue.

This was super interesting to me, so I went and did this:

Exported a Pokemon (that is normal, no issue) from Pokemon X and put it into my Pokemon Y save that I dont play and therefore, hadn't seen that pokemon (Luvdisc in this case). And surprise, it became Shiny.
YOU being able to reproduce the issue should tell me that nothing is wrong with my PKHeX. 
My Pokemon Y producing the same issue as X should tell me its not just a bugged Pokemon X ROM.
However, when these same Pokemon X pokemon were dumped into my ALPHA SAPPHIRE ROM, they did NOT appear shiny. Now this one is controversial for me, I dont know if Pokedex can even show shiny forms as default in Alpha Sapphire.
Before you replied to this thread, I took this as my "temporary solution", that I'd transfer them all to Alpha Sapphire and just ignore the fact that something is going on with Pokemon X.
But taking all three points above into consideration, where is the issue arising from?
I'm fine with not getting an answer at this point but maybe people want to discuss it if they want and discover the root of the problem if not the solution.

Share this post


Link to post
Share on other sites
Guest

I think that might just be it, it's setting the Seen and Owned flags, but not the Language and Displayed flags. But from there, there are two possibilities:

1: PKHeX isn't setting the flags at all (best case scenario)
2: PKHeX is attempting to set those flags, but at the wrong offsets, resulting in unrelated data being edited

If 1: is the case, you're in luck, because this means you can just manually go through the Pokédex list in PKHeX and set the Displayed and Language flags accordingly, and it'll solve your issues. If 2: is the case however, I probably wouldn't recommend continuing to use your edited save file, because we don't know what data might have been incorrectly modified and what kind of side-effects it could have.

These kind of things happen far more often than you might think, mind you. I don't think I even have enough fingers on one hand to count how many times Pokédex flags handling has been screwed up in-between PKHeX updates. Code refactors tend to introduce regressions like that.

I'll go back through commits and find a release where everything hopefully works as expected.

Share this post


Link to post
Share on other sites
1 minute ago, Ammako said:

I think that might just be it, it's setting the Seen and Owned flags, but not the Language and Displayed flags. But from there, there are two possibilities:

1: PKHeX isn't setting the flags at all (best case scenario)
2: PKHeX is attempting to set those flags, but at the wrong offsets, resulting in unrelated data being edited

If 1: is the case, you're in luck, because this means you can just manually go through the Pokédex list in PKHeX and set the Displayed and Language flags accordingly, and it'll solve your issues. If 2: is the case however, I probably wouldn't recommend continuing to use your edited save file, because we don't know what data might have been incorrectly modified and what kind of side-effects it could have.

These kind of things happen far more often than you might think, mind you. I don't think I even have enough fingers on one hand to count how many times Pokédex flags handling has been screwed up in-between PKHeX updates. Code refactors tend to introduce regressions like that.

I'll go back through commits and find a release where everything hopefully works as expected.

@Ammako Thank you so much for detailed info as I'm not well aware of how it all works. But all I have to say for now is, take your time. My issue isn't as important and don't stress over it if you can't find an answer. I Appreciate the help but at the same time I dont wanna cause any inconvenience or bump this thread over others that might have important issues to deal with. I'll keep checking this thread every few hours except at night to make sure I can provide you with whatever info you need from my side. 

Share this post


Link to post
Share on other sites
Guest

I have nothing better to do, so no worries.

By the way, I think you may have uploaded the wrong save file for AS; this one seems to be a Y save file.

I can also tell you that this is not an issue exclusive to your save file, I got a save file from someone who dumped theirs from real hardware and the same thing happens with that one.

Edited by Guest

Share this post


Link to post
Share on other sites
24 minutes ago, Ammako said:

1: PKHeX isn't setting the flags at all (best case scenario)
2: PKHeX is attempting to set those flags, but at the wrong offsets, resulting in unrelated data being edited

not doubting you, but just pointing out that in this case, PKHeX being rather inconsistent?

As per my mini tutorial above, when I wipe out the seen/caught flags, it does wipe out the language flags as well.
image.png

Meaning that for my example earlier, PKHeX was assigning languages, hence why I could see my imported dex entries afterwards.
 

edit: Yup, was checking a Celebi (Japanese entry) to see what language was assigned to it, and it didn't assign any.
image.png
However, it doesn't appear shiny in-game tho. (correct Seen/Owned)
image.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...