Jump to content
StarsMmd

xd Pokemon XG: NeXt Gen

Recommended Posts

13 minutes ago, macerator_mmg said:

Hello,

I just found this and was trying to patch my .iso of the game with the .ups i downloaded using NUPS but i keep getting an error saying "the patch doesn't match the file, patching canceled". How do I solve this? I'm really looking forward to being able to use this, Thanks for any help!

I'm not sure why you're getting that error, but the version of the game I use is the NTSC version and it works for me.

8 hours ago, Emalisha said:

I'm pretty sure it's Aerodactyl.

And correct, Dratini is one too.

Alright, thanks!

Share this post


Link to post
Share on other sites

New yo this, just a question: last time I played XG it was v.1.0.4, and so I patched a clean ISO with v.1.1.8 to see if the save files we're compatible, wich they weren't and still ran the v.1.0.4 save file. Will starting a new game let me play the v.1.1.8 patch?

Share this post


Link to post
Share on other sites
On 12/4/2018 at 10:21 PM, macerator_mmg said:

Hello,

I just found this and was trying to patch my .iso of the game with the .ups i downloaded using NUPS but i keep getting an error saying "the patch doesn't match the file, patching canceled". How do I solve this? I'm really looking forward to being able to use this, Thanks for any help!

Apply the patch to a clean .iso. (so not an XG one, but an XD one)

What I did was keep a clean iso in a separate folder and copy it each time there was a new patch and applied the patch to that copy.

8 hours ago, chipsNguacamole said:

New yo this, just a question: last time I played XG it was v.1.0.4, and so I patched a clean ISO with v.1.1.8 to see if the save files we're compatible, wich they weren't and still ran the v.1.0.4 save file. Will starting a new game let me play the v.1.1.8 patch?

Of course ! Try to export your save first, in case someone would be able to help you out. Just click on "tools" then "Gamecube Memory Card Manager". Image in spoilers below!

Spoiler

44727574_ss(2018-12-06at05_58.00).png.89cd76c845ff71b7203e6ae1393c2628.png

Really not sure if that will work, but maybe you could try to load a savestate? Would be interesting to know what would happen in that case.

If you still wanna keep a regular save and not using save states, you can make a new file on v1.1.8, save, load state (if it works) and then the game should let you resave normally. Once again, if loading a state works... Really don't know how that stuff works since all I knew was that there were some differences in the saves because of the patches, never heard about incompatible saves because of it.

Edited by Emalisha

Share this post


Link to post
Share on other sites

Hey Stars! I know you get this a lot, but I made an account so I could post in this thread. Thanks for all of your hard work, I've spent probably around 200 hours between all of the hacks and such that you've worked on (and still growing too!).

I'm playing version v.1.1.8,  and I used your XD randomizer on it. I got to the point in the game where I can get Pokemon from Pokespots, but I think that because all of those Pokemon are randomized too, it's making the game crash. I enter the Pokespot where a Pokemon is and the screen is black with the music continuing for a few seconds before the game crashes. I have a feeling it's probably something relating to the Pokemon models that are supposed to show up, maybe?

I play this game so often that if I run into something else, I'll be sure to let you know! Thanks again Stars, you rule!

Share this post


Link to post
Share on other sites
On 12/4/2018 at 4:21 PM, macerator_mmg said:

Hello,

I just found this and was trying to patch my .iso of the game with the .ups i downloaded using NUPS but i keep getting an error saying "the patch doesn't match the file, patching canceled". How do I solve this? I'm really looking forward to being able to use this, Thanks for any help!

You need an ISO with the following hashes:
CRC32: C0F69D18
MD5: 3BC1671806CF763A8712A5D398F62AD3
SHA-1: C1B5218F832403D15AA500AC4D6AACC8865C792D

If the ISO you have does not have those hashes, patching will fail. You need a different ISO.

Share this post


Link to post
Share on other sites

Hey, @StarsMmd, is there an ETA on when 1.2.0 will be available? I can wait, but thought there might be an ETA since the changelog for 1.2.0 is listed in OP, but there is not a download link yet.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×