formlesstree4

Shiny2 Distribution System

145 posts in this topic

Recommended Posts

Hey, I'm a big fan of these GTS-emulators, and I got very frustrated a few months ago when IR-GTS stopped working for me. So, after I finished school for the year, I've been looking around for other programs to use, but nothing seems to work. So, I'm going to try to get this one working.

I used the Open Port Check Tool (on the OP) and it says my Port 53 isn't reachable (Connection timed out). I think this might be the issue that's been holding up my GTS-ing for months. The only issue is I've made rules for my Windows Firewall (I have Windows 7) allowing both ports 80 and 53 to be open on the right protocol. I've also used my Router's Port Forwarding to allow both ports, again with the proper protocol.

So my question is what do I do now? I've tried everything I can think of, but nothing seems to be working. I've checked my computer for anything using those two ports, but come up with nothing. Has anyone else had these problems?

Thank you for your help in advance.

Share this post


Link to post
Share on other sites
Hey, I'm a big fan of these GTS-emulators, and I got very frustrated a few months ago when IR-GTS stopped working for me. So, after I finished school for the year, I've been looking around for other programs to use, but nothing seems to work. So, I'm going to try to get this one working.

I used the Open Port Check Tool (on the OP) and it says my Port 53 isn't reachable (Connection timed out). I think this might be the issue that's been holding up my GTS-ing for months. The only issue is I've made rules for my Windows Firewall (I have Windows 7) allowing both ports 80 and 53 to be open on the right protocol. I've also used my Router's Port Forwarding to allow both ports, again with the proper protocol.

So my question is what do I do now? I've tried everything I can think of, but nothing seems to be working. I've checked my computer for anything using those two ports, but come up with nothing. Has anyone else had these problems?

Thank you for your help in advance.

You might have something utilizing the port. Besides, Port 53 is UDP (connection-less). There's no guarantee that any program, without a receiving program ready, can listen to it. Honestly, it's a hit and miss, and, just because you actually did forward it, doesn't mean your router is actually forwarding them properly. I've had that issue before. O.o

Share this post


Link to post
Share on other sites

Do i just have to have my external IP address to distribute to myself? I want to try my own distro because every time i try another now it ignores the dns and goes straight to the real gts, i want to see if this will be different!

Share this post


Link to post
Share on other sites

I was lucky enough not to get a virus after going to that link on "Connections to the program fail!" to learn how to port forward when my dad tried to do it for me! Thought you should know!

EDIT: Never mind this, my computer said there was a virus, then i figure out there was never one! Sorry about that!

Edited by StreetPunkism

Share this post


Link to post
Share on other sites
I was lucky enough not to get a virus after going to that link on "Connections to the program fail!" to learn how to port forward when my dad tried to do it for me! Thought you should know!

EDIT: Never mind this, my computer said there was a virus, then i figure out there was never one! Sorry about that!

What do you mean? Can you elaborate for me?

Share this post


Link to post
Share on other sites

I have not stopped working on this! As far as I know, Shiny2 is 100% compatible with Black 2 and White 2. I'm working on more stability updates as well as an update to the template system, so hopefully that will be out soon.

Share this post


Link to post
Share on other sites
I have not stopped working on this! As far as I know, Shiny2 is 100% compatible with Black 2 and White 2. I'm working on more stability updates as well as an update to the template system, so hopefully that will be out soon.

So happy to hear this, love your program! :bidoof:

Share this post


Link to post
Share on other sites
So happy to hear this, love your program! :bidoof:

Thanks for the support! I've also finally wrote in code to detect whether or not a request submitted is a DS or not.

Share this post


Link to post
Share on other sites

Hey there, I figured I'd chime in with my experience trying Shiny 2 on pokemon white 2. I can get IRGTS to work just fine for transferring pokemon with the same ports forwarded and IP. However Shiny 2 gets a connection error 13275 on Checking GTS... The last log item in Shiny 2 just says sent XXX bytes and stops there. I've tried on three of my home computers and disabled the firewalls on all of them. Also tried in a virtual machine of windows 7 with no anti virus/firewall.

Edit: Just checked again, I can receive from white 2 on all my computers but I can't send. It always ends in a connection error.

Log:

11:02 AM: *** ShinyJirachi's Fake DNS server v0.6 ***

11:02 AM: *** Based on Fake DNS server v0.5 by RoC ***

11:02 AM: *** Based on ShinyJirachi Fake DNS server v0.4 ***

11:02 AM: *** Based on M@T's Fake DNS server v0.3 ***

11:02 AM: *** Based on LordLandon's sendpkm.py ***

11:04 AM: Incoming data from 192.168.1.2!

11:04 AM: 192.168.1.2 has requested conntest.nintendowifi.net!

11:04 AM: Sending reply to 192.168.1.2!

11:04 AM: Incoming data from 192.168.1.2!

11:04 AM: 192.168.1.2 has requested syachi2ds.available.gs.nintendowifi.net!

11:04 AM: Sending reply to 192.168.1.2!

11:04 AM: Incoming data from 192.168.1.2!

11:04 AM: 192.168.1.2 has requested nas.nintendowifi.net!

11:04 AM: Sending reply to 192.168.1.2!

11:04 AM: Incoming data from 192.168.1.2!

11:04 AM: 192.168.1.2 has requested gpcm.gs.nintendowifi.net!

11:04 AM: Sending reply to 192.168.1.2!

11:04 AM: Incoming data from 192.168.1.2!

11:04 AM: 192.168.1.2 has requested nas.nintendowifi.net!

11:04 AM: Sending reply to 192.168.1.2!

11:04 AM: Incoming data from 192.168.1.2!

11:04 AM: 192.168.1.2 has requested nas.nintendowifi.net!

11:04 AM: Sending reply to 192.168.1.2!

11:04 AM: Incoming data from 192.168.1.2!

11:04 AM: 192.168.1.2 has requested gamestats2.gs.nintendowifi.net!

11:04 AM: Sending reply to 192.168.1.2!

11:04 AM: Incoming data from 192.168.1.2!

11:04 AM: 192.168.1.2 has requested gamestats2.gs.nintendowifi.net!

11:04 AM: Sending reply to 192.168.1.2!

11:04 AM: Incoming data from 192.168.1.2!

11:04 AM: 192.168.1.2 has requested gamestats2.gs.nintendowifi.net!

11:04 AM: Sending reply to 192.168.1.2!

11:04 AM: Incoming data from 192.168.1.2!

11:04 AM: 192.168.1.2 has requested gamestats2.gs.nintendowifi.net!

11:04 AM: Sending reply to 192.168.1.2!

11:04 AM: Incoming data from 192.168.1.2!

11:04 AM: 192.168.1.2 has requested gamestats2.gs.nintendowifi.net!

11:04 AM: Sending reply to 192.168.1.2!

11:04 AM: Incoming data from 192.168.1.2!

11:04 AM: 192.168.1.2 has requested gamestats2.gs.nintendowifi.net!

11:04 AM: Sending reply to 192.168.1.2!

Edit2: Now it started working again... randomly... after 5-9 failed attempts, it appears that I can only send pkm files that shiny 2 has generated from the game itself. IE stuff I've sent to shiny GTS I can send back but not files I've digged up from elsewhere.

Share this post


Link to post
Share on other sites
Hey there, I figured I'd chime in with my experience trying Shiny 2 on pokemon white 2. I can get IRGTS to work just fine for transferring pokemon with the same ports forwarded and IP. However Shiny 2 gets a connection error 13275 on Checking GTS... The last log item in Shiny 2 just says sent XXX bytes and stops there. I've tried on three of my home computers and disabled the firewalls on all of them. Also tried in a virtual machine of windows 7 with no anti virus/firewall.

Edit: Just checked again, I can receive from white 2 on all my computers but I can't send. It always ends in a connection error.

Log:

Edit2: Now it started working again... randomly... after 5-9 failed attempts, it appears that I can only send pkm files that shiny 2 has generated from the game itself. IE stuff I've sent to shiny GTS I can send back but not files I've digged up from elsewhere.

I honestly have no idea as haven't been able to try White 2 just yet (so I can't see if anything has really changed, but my sources have told me things haven't). I haven't changed anything since I first built Shiny2; it's literally sending the same data as IR-GTS. Can you send me the Pokemon files you're having issues with? I'll try running them through my local copy of Shiny2. Try ticking the verbose option inside the settings and running it again.

Share this post


Link to post
Share on other sites

ok, i ran this once, got an error, but silly me didnt save the error info, and now the app wont open. when i double click it, it shows up in processes, but i dont see anything open on the desktop. how do i solve this problem?

Share this post


Link to post
Share on other sites
ok, i ran this once, got an error, but silly me didnt save the error info, and now the app wont open. when i double click it, it shows up in processes, but i dont see anything open on the desktop. how do i solve this problem?

Kill the process and delete any text files and INI files in the directory. When you run it again, let me know the errors, if any appear. I'm working on a new interface that'll be a bit better to work with.

Share this post


Link to post
Share on other sites
Kill the process and delete any text files and INI files in the directory. When you run it again, let me know the errors, if any appear. I'm working on a new interface that'll be a bit better to work with.

that fixed the problem, thanks!

Share this post


Link to post
Share on other sites
that fixed the problem, thanks!

No problem.

I'm sure you already heard this, but this software is amazing. You have my sincerest thanks.

Always nice to hear it again :)

Share this post


Link to post
Share on other sites

This looks like an amazing piece of programming. I used the IR GTS for a while in order to get stuff like the events that were across the country-like Celebii and Mew. Like some of the other posters here I was disappointed to find it had been canceled. I'm attempting to use this and it seems to start up as planned but the DSi unit refuses to connect to the GTS-I keep getting various errors but the most common one is 52110. From what I have seen I am guessing that the IP address and DNS servers listed in the laptop/pc settings are the ones to put manually into the DSi in order to use the Shiny2 program for local distribution(trading to myself). Is this the correct input to the internet connection options? I don't think a firewall is the problem because although it has popped up on my firewall it gave me the option to let it through and that seemed to work fine, but I keep getting the connection errors on the DSi. It is late where I am and I'll keep trying tomorrow after I wake up, any advice or help would be much appreciated. Thanks again for the great work here

Share this post


Link to post
Share on other sites
This looks like an amazing piece of programming. I used the IR GTS for a while in order to get stuff like the events that were across the country-like Celebii and Mew. Like some of the other posters here I was disappointed to find it had been canceled. I'm attempting to use this and it seems to start up as planned but the DSi unit refuses to connect to the GTS-I keep getting various errors but the most common one is 52110. From what I have seen I am guessing that the IP address and DNS servers listed in the laptop/pc settings are the ones to put manually into the DSi in order to use the Shiny2 program for local distribution(trading to myself). Is this the correct input to the internet connection options? I don't think a firewall is the problem because although it has popped up on my firewall it gave me the option to let it through and that seemed to work fine, but I keep getting the connection errors on the DSi. It is late where I am and I'll keep trying tomorrow after I wake up, any advice or help would be much appreciated. Thanks again for the great work here

Unfortunately without further information I can't exactly tell you what's wrong. It can be a slew of things, from a simple as port forwarding on your local machine, to your firewall still interfering, to the DSi just being a pain in the tush. If you're distributing locally, you need to get the IP address that your router gave to you. However, if you are -not- going local, you can use the simple "Detect IP" button and it'll do it for you. As for your DSi options, the Primary DNS Server should match the IP address that you put into Shiny2. One of these days I'm going to get a tutorial around to actually setting this thing up for you guys.

Share this post


Link to post
Share on other sites
As far as I know, it works. The GTS protocol has not changed for B/W 2.

i can use shiny 2 to send Pokemon to black 2, but i cant use it to receive Pokemon from black 2

Share this post


Link to post
Share on other sites

Hi, I'm having a problem sending Pokemon to my computer. Here's what I've done:

- Receive - Black and White

- IP address = IPv4

- DNS is set up proplerly

- DNS and GTS are running properly

- I can connect to WiFi on my 3DS without issue

- I can connect to GTS in White 2 without issue

- I upload a Pokemon to GTS, but Shiny2 never receives them

I haven't tried receiving Pokemon yet (because I don't know how to create .PKM files, and all I want to do is make the Pokemon I caught in-game have their maximum possible stats, EVs, etc.), but if Dele's report is accurate then I should be able to receive them anyway...

Share this post


Link to post
Share on other sites
i can use shiny 2 to send Pokemon to black 2, but i cant use it to receive Pokemon from black 2

Receiving might be borked in the latest version, I can't remember.

Hi, I'm having a problem sending Pokemon to my computer. Here's what I've done:

- Receive - Black and White

- IP address = IPv4

- DNS is set up proplerly

- DNS and GTS are running properly

- I can connect to WiFi on my 3DS without issue

- I can connect to GTS in White 2 without issue

- I upload a Pokemon to GTS, but Shiny2 never receives them

I haven't tried receiving Pokemon yet (because I don't know how to create .PKM files, and all I want to do is make the Pokemon I caught in-game have their maximum possible stats, EVs, etc.), but if Dele's report is accurate then I should be able to receive them anyway...

Your 3DS needs to have the DS Wifi Options adjusted, not the regular WiFi options adjusted. I found this out second hand from somebody else.

Share this post


Link to post
Share on other sites
Your 3DS needs to have the DS Wifi Options adjusted, not the regular WiFi options adjusted. I found this out second hand from somebody else.

I just tried adjusting my DS WiFi settings, but it turns out I can't connect to WiFi with my router because I have WPA security, not WEP. ...But I can still connect to WiFi in the game? :confused:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now