Jump to content

IR-GTS-BW Release


Recommended Posts

  • Replies 263
  • Created
  • Last Reply

Top Posters In This Topic

hi, are you able to change the code in such a way that it does not keep prompting you when you upload a pokemon with the same nickname?

I might be able to do this for a future release, if I ever get time to work on it again.

I have attached a picture of the window showing the error.

IR-GTS doesn't like file paths that have special characters in them, notably accented letters (like the ö in your attached image). Sorry, it's not particularly international-friendly. To fix this, you should be able to either move the files to a path that doesn't have characters like that, or change the ö to an o.

The program won't allow me to drag the .pkm file into the window. Everything else works (as long as I manually type in the filepath every time, but it is getting a little irritating for me to have to do that). I'm not sure what's going on.

What's your OS?

Link to comment
Share on other sites

Hi,

I use Cox for internet with a linksys e3000 wireless n router with wpa2-psk encryption. I've tried both of my computers with admin accounts but neither of them work. Are there any certain programs which I need to turn off, or is it my hardware to blame? (I don't use the wireless n, but it is still on) What programs, excluding skype or steam, can cause this issue?

Link to comment
Share on other sites

I might be able to do this for a future release, if I ever get time to work on it again.

IR-GTS doesn't like file paths that have special characters in them, notably accented letters (like the ö in your attached image). Sorry, it's not particularly international-friendly. To fix this, you should be able to either move the files to a path that doesn't have characters like that, or change the ö to an o.

What's your OS?

My OS is Windows Vista x64

Link to comment
Share on other sites

I've tried using this thing with my primary and secondary DNS's both together and individually and none of them work. I get Error 52110 whenever I use primary or both and just the regular DNS when I only use secondary. This was when I used my old windows xp desktop. It was with an earthlink internet connection and a D-Link DI-524 router. External DNS's work fine but my computers does not. I'm also using a 3DS system for this. What can I do to make my computer's DNS work? FYI, I've already tried with the firewall, doesn't work even when disabled so the firewall isn't doing anything to block it.

Link to comment
Share on other sites

I've tried using this thing with my primary and secondary DNS's both together and individually and none of them work. I get Error 52110 whenever I use primary or both and just the regular DNS when I only use secondary. This was when I used my old windows xp desktop. It was with an earthlink internet connection and a D-Link DI-524 router. External DNS's work fine but my computers does not. I'm also using a 3DS system for this. What can I do to make my computer's DNS work? FYI, I've already tried with the firewall, doesn't work even when disabled so the firewall isn't doing anything to block it.

I'm having somewhat of the same problem.

I am working on my Laptop (Windows XP), which in turns uses Wifi from my router. Does this impact anything?

When I turn Windows Firewall off and uninstall Microsoft Security Essentials, I get the exact same results as when they were both active. At first I begin to connect, with strong green bars, then after a few seconds it just jumps to red and I disconnect.

Is there anything that can be done? Should I try to use my desktop instead? Or is it a problem with my ISP and therefore hopeless?

Link to comment
Share on other sites

  • 2 weeks later...
  • 2 weeks later...

I have the error of 52100. The connection bar starts off at full then disappears and becomes red. Any advices will be appreciated & Thank You in advance :)

Har Har 1'st Post...im suck a Lurker :3

Edited by Lags
idk ;-;
Link to comment
Share on other sites

My DS keeps coming up with the error code 52100. I have followed all the steps of the readme, fixed every issue the Common Issues page says may be causing it, and checked that the number for DNS is in fact my computer's IP. I have scanned through this whole page and found no solutions. It seems to be connecting to the GTS but then suddenly goes from 3 bars to none and says "Unable to connect to Wi-Fi Connection Check your connection settings and try again."

Link to comment
Share on other sites

I've found out something weird.

When I receive Pokémon from IR-GTS-BW, it adds a Pokémon Breeder to the Tanzania floor of Unity Tower that has the same OT as the Pokémon I sent.

So now I have Pokémon Breeder ハドウ, ネガイボシ, ミツリン, CHARLIE and some other thing in the Tanzania floor of Unity Tower.

Link to comment
Share on other sites

  • 2 weeks later...

Is there a set by set guide how to use this program? How do i change my dns, and i just change my dns to the one its telling me too?

When i go to change my dns settingings on my ds, it tell me to put in primary dns so i do. But what do i put in for gateway, subnet mask, and ip address?

Link to comment
Share on other sites

So i fixed my last problem, but now i have a knew one. Everything was working fine, i was sending and receiving just fine. Then i tried to receive again awhile later and i got this error message:

"unhandled exception in thread started by <function dnsspoof at 0x020f39bo>

traceback <most recent call last>:

file "C: \users\merf\desktop\pokemon\ir-gts-bw\pokehaxlib.py", line 77, in dnsspoof

r+dnsserv.recvfrom<512>

socket.error: [errno 10054] An existing connection was forcibly closed by the remote host."

What does this mean, and what should i do?

Link to comment
Share on other sites

Ok I'm using the latest download from the website v0.05 and I can send Pokemon from my DS to my pc just fine. For some reason I am having problems sending from PC to my DS. The program isn't taking any PKM file. I've even tried using the ones I sent from my DS with this, yet I can't send it back. I am unable to drag and drop, and when I type in the directory, it displays a long error code and instantly closes. Is there a way to fix this? (PS I've tried running it in the CMD and same results, only difference is that it doesn't close after the error message displays)

Link to comment
Share on other sites

Could someone PLEASE help!? I have got Python 2.7 and pokegen, tried making a Zorua, blah blah blah. But every time I change the DNS settings to what ir GTS told me to, the DS can't connect and gets error 52101. I've disable my norton firewall and antivirus but it still doesn't work. I am on a Windows XP and am using a Nintendo USB Wi Fi Connector and a wireless router to connect if it makes any difference. PLEASE HELP!! (I am using the beta ir GTS for Pokemon White cause that's what I have.)

Would an action replay be easier than this to get the exact pokemon I want?

Link to comment
Share on other sites

Running Linux and Python 2.6.5

found a issue when receiving a Pokemon

it seems it does not look for the Pokemon folder in the right place unless you cd to the folder it is in

me@lucid-lynx:~$ sudo ~/Documents/Pokemon/ir-gts-bw/ir-gts-bw.py

got a error receiving involving the folder path

if i do this first it works

me@lucid-lynx:~$ cd ~/Documents/Pokemon/ir-gts-bw/

me@lucid-lynx:~$ sudo ./ir-gts-bw.py

After you save the pkm to a file could you have it chown the file to $USER:$USER so that it is not owned by root (chown $USER:$USER ./Pokemon/Pikachu.pkm)

anyone know hot to get this working across a router with port forwarding?

the only port i see running in it is port 80, i forwarded it and 53 did not work on the other side of my router

I like that this is in python for cross platform support

EDIT:

Port 53 uses UDP not TCP

Edited by sdfghjklkjhgfds sdfghjiuy
Link to comment
Share on other sites

Hi!

I am having a problem. I created a pkmn using pokesav. I have set up my connection at the NDS.

I can send the pkmn in irgts. The test connection of the NDS does work (where you can configure the access points and such stuff). However, I cannot connect to my "faked" GTS. I dont get a connection.

The windows firewall is turned off just to be sure.

OS: Win 7 ultimate x86

Thanks for your help!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...